General discussion

Locked

Canon USB Scanner Driver Problem

By jpenuel ·
I am trying to install a LiDE 30 USB scanner on an IBM NetVista PC (P4 1.8 mhz, 256 MB RAM, Windows 2000 Professional, Service Pack 4). I had previously installed a Canon N1220U USB scanner on this same PC. When I installed the new scanner, it would not connect to the applications.

Under device manager>imaging devices, there is a yellow circle with an exclamation mark. Under properties, I see the following error message: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31).

I have tried multiple solutions, so far without success. I have searched the Canon support site and also the Microsoft knowledge base and have been unable to find any information that specifically addresses this problem. The scanner is unlocked and it functions normally when connected to my HP laptop computer.

I tried uninstalling the scanner via device manager and reinstalling. I have also tried multiple variations of uninstalling everything and then reinstalling, with reboots after the deletes, and also after the installs. I have also deleted all the files in the temp directories.

I have downloaded the Canon deldrv utility and deleted the drivers for both the N1220u and the LiDE 30, and deleted all the Canon applications. I then reinstalled the drivers for the LIDE 30 from CD, rebooted, and still get the code 31 error in device manager. I tried cleaning everything off again, and installed the latest drivers from the Canon web site.

I feel like I must be missing something here. Is there a registry key that is preventing the driver from loading? I think there must be something else that needs to be removed before I can successfully install this scanner.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by dmiles In reply to Canon USB Scanner Driver ...

Download the Twain driver in a location on the drive,take note of location

Unplug the scanner from system and start the install process from the beginning,connect the USB port to system,before loading software,locate the twain driver and install it,
when the driver install is complete,proceed to install the software

Collapse -

by jpenuel In reply to

This did not work. Driver install is via Scangear application install.

Collapse -

by sgt_shultz In reply to Canon USB Scanner Driver ...

well, installing twain ain't gonna get rid of that yellow bang in device manaqaer...
ah, windows 98.
this sounds exactly like what happened to me with usb printer both old and replacements were same brand. (in this case lexmark). what was happening is that install program found wrong inf. fix was to (re)move the bad drive AND inf so installer had to find good inf. if you watch the screen carefully during install you will see the inf it finds and thinks it wants to use. right it down and ditch that one. i had to do this twice and find and ditch 2 old lexmark infs before it installed.
i would have expected the deldriver util from canon to do this but who knows? i bet this is documented in canon support kb if you looked up by code 31. did you search mskb for code 31?
and do you have latest greateds usb 2 support in win98 and mboard.

Collapse -

by jpenuel In reply to

This gave me some potential clues, but did not resolve the problem. As I stated above, OS is W2K Pro. I found the driver file and renamed it (oem35.inf). Reinstalled from CD--No change. This file did reappear after install routine.

I finally got in touch with Canon tech support by phone. Their email link was not working. They suggested the following routine:
explorer>tools>folder options>show hidden files
search for cnql*.*
delete all
uninstall scanner from device manager
unplug scanner
run deldrv utility
reboot
reinstall

Still got the "yellow bang."
I looked through the list of driver files and repeated the above process, manually deleting all the identifiable driver files. Same result.
I have thoroughly searched MKSB and Canon Web site and found no references that specifically address this problem.

At this point, it appears that Canoscan scanners are no longer on my A-List. I have expended far more energy than the scanner is worth.

Any more ideas? I am really frustrated. It should not be this difficult to install a scanner. SCSI install would be easier.

Collapse -

by BigSchmuh In reply to Canon USB Scanner Driver ...

Sorry about that, I do not have an answer but I share the same kind of problem with a CanoScan N670U.
W2K does recognize the driver and show the N670U from its Scanner control panel tab but it does not work. It claims for a cable connection error but my dual boot pc perfectly handles it from Win98.
I tried Canon support recently but I did not have any news till now...
==> Looks like I am stack to Win98 (which refuses to shutdown but does recognize my 2d hotmail account and this N670U scanner)

Collapse -

by jpenuel In reply to

Poster rated this answer.

Collapse -

by jpenuel In reply to Canon USB Scanner Driver ...

I think I have found the answer. I also have a Visioneer Strobe Pro scanner installed. I disconnected this scanner, and heard the Canoscan starting up. Apparently, these two scanners cannot peacefully coexist on my PC.
This was a lot of flailing around to solve a relatively simple problem. I suppose I should have thought of this myself, but even Canon Tech support overlooked this solution, and I recall informing them of the other scanner when we were going through the uninstall process, ripping out all the registry entries, etc.

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums