General discussion

Locked

Can't access bios

By chrisshaw68 ·
Trying to sort a freinds pc. On startup the bios info flashes before memory check etc, but can't get any further.
The Pc just keeps switching on/off, but never getting past the first screen. Tried cont/alt/delete etc but nothing.
Can't boot from any drive either.
This pc was working fine, no hardware added or taken away. Help please

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sgt_shultz In reply to Can't access bios

try a new keyboard just to make sure

Collapse -

by chrisshaw68 In reply to Can't access bios

Tried the keyboard and mouse....no change

Collapse -

by chrisshaw68 In reply to Can't access bios

Tried the keyboard and mouse....no change

Collapse -

by EStreetJerseyGirl In reply to Can't access bios

Hi! I had this problem with a friend's computer as well. It was an IBM NetVista that was 2 years old - working fine, then one day it went into seizure mode, caught in a constant rebooting loop. It turned out that it was a faulty motherboard; the capacitors by the processor had acid on them - a problem with this model of computer - and IBM replaced the motherboard for free.

I'd suggest taking the cover off the tower and just having a look at the motherboard. The capacitors (round tube-looking things about the diameter of a pencil, some bigger, some smaller) should not look like exploded batteries; there shouldn't be any "yicky-looking" stuff on them. If this is, in fact, what's wrong with the computer, call the manufacturer and they will replace the motherboard for FREE! Also a kool thing to note: it doesn't matter if the computer is still under warranty or not, they will still replace the motherboard for free.

Hope this helps!

~Jennifer

Collapse -

by willcomp In reply to Can't access bios

Try a simple one first. Reset the BIOS. You should have a jumper on mobo that will rest BIOS to default settings. See either your manual or manufacturer's web site if location of jumper is not apparent. It usually is a 3 pin jumper with 2 pins shorted. Move jumper to other 2 pins and power up. Either follow instructions provided or shutdown, reset jumper to original position, and reboot.

This has a small success rate but is simple and quick and worth a try. You just may be lucky.

Leaking caps usually, but not always, will prevent power up. The most stressed are in power circuitry maning they fail first and drop power to mobo. But do inspect them and other internal components as well.

Also try removing all cards except video card and disconnect power leads from drives. Try to boot with minimal configuration and see what happens.

Your probelm could also be memory or power supply related. Swap them out with known good components if you can.

Good Luck

Back to Desktop Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums