Question

Locked

Can't access Linux Partition

By jefw ·
I have a 200gb hard drive. I picked it up for free because Windows XP only recognizes 38gb. After doing some trouble shooting I found one utility that found a Linux partition on the drive. Which explains why XP only saw 38gb.

Of course it didn't give any info about the partition or what kind it is. I've tried multiple Linux utilities and booted from floppies to access that drive but they do not see the Linux Partition. I have no idea what variable was used to create the partition. The Linux utilities I've used search for the most common linux partitions. Without knowing which linux variance created the partition, am I sunk?? I just want to delete that partition to recover the rest of the drive. Of course Windows XP doesn't recognize it and fdisk for Windows won't work. I continue to try multiple Linux Utilities until I find the right one that will recognize the linux partition. I'm almost out of options. Any ideas?? Thanks.

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

OH Yes it does. :^0 :^0

by HAL 9000 Moderator In reply to Can't access Linux Partit ...

Use a Windows 98 Boot Disc and then when you get to the Dos Prompt type in FDISK. Naturally you'll need this Disc installed in the machine and it would be better if it's the only one in it. Chose to Delete Partitions and then chose the Non DOS Partition and this will delete the partition what ever it actually is as this doesn't sound like a Nix Partition but something else completely.

The only possible problem you can have with the FDISK Utility is if this is a SATA HDD then you'll need to download one of the Boot Disc's that are available on the Net and make sure that you pick one with general purpose SATA Drivers included. The directions are still the same though once you can see the SATA Drive you chose the Remove Partition heading and then Remove Non DOS Partition.

This is so easy I could do it in my sleep without even twitching an eyelid. :0

Another option is to use a wiping utility like Boot & Nuke that will write zero's to every sector of the drive and thus destroy everything that may be on that partition whatever it actually is. It's available here for download

http://tinyurl.com/4rfur

Col

Collapse -

Not!

by jefw In reply to OH Yes it does. :^0 :D ...

Sorry, Windows 98 boot does not recognize Linux partitions. Tried it, didn't work. Why would Microsoft want to let their software read a competitors code anyways? I've read too much lately to read that over and over. Yes I could run fdisk and yes it formatted and recreated a partition (and the hard drive it thought) but it will only recoginize the partition that it saw. Which of course was a NTFS partition. I doubt that Win98 fdisk recognizes the most recent Linux partitions that are out there.

No Raid running on this system so no issue to worry about there.

Boot and Nuke. Not! Tried it. Yes it booted and nuked but it but only did the 34gig partition that it recognized. And I used the many of its options to write to all the sectors it could find. (The entire hard drive it thought)

Perhaps the hard drive was dead right out of the box. You wouldn't be able to fix this one in your sleep or awake! :)

Thanks anyways.

Collapse -

Well firstly FDISK is a DOS Utility

by HAL 9000 Moderator In reply to Not!

And MS at the time that it was being used had products available that where not DOS Based namely NT so you have the option in FDISK to delete the Non DOS Partition. That can be a FAT 32 as a DOS Partition is a FAT8 or maybe on the latter versions a FAT16 and at a real push a FAT 32 but FDISK will never see a NTFS Partition in a manner that is readable it will just report that there is a Non DOS Partition there and then you use Option 4 in the removing partitions of FDISK to remove the Non DOS Partition.

Technically speaking you can not see the contents of any NTFS Partition with FDISK but you are still able to delete them when you want to with FDISK so are you attempting to say that FDISK is incapable of deleting NTFS Partitions or even NFS Partitions? As it most certainly is not.

Just out of curiosity what brand of HDD is this?

Have you actually looked at the Jumper Settings and here I do mean really look as some HDD had a size limit of around the 40 GIG with 1 jumper setting so it's possible that the drive has been locked to the 40 GIG size and that the other what you think is a partition is wasted space as it's been disabled by hardware. You may need to actually look up the drive makers web site here and down load their Jumper Settings Paper.

The reason that I ask this is that if Boot & Nuke is unable to remove the entire contents of the drive there is a reason and it's absolutely nothing to do with Partitions there is something else at play here and that makes this an interesting question even if you seem **** bent on taking offence and not providing enough information. But would prefer to turn this into a Flame War over nothing but your own ego.

Don't believe me use a 98 Boot Floppy type in FDISK then chose the remove Partitions or Logical Partitions and when you see the Non DOS partition look at the available options and you'll see that there is an option to remove a Non DOS Partition if this isn't working it's not because FDISK is incapable of removing that partition but there is something else there preventing anything accessing this part of the HDD and it has to be hardware related not software so M$ has no control over this in any way shape or form.

Col

Collapse -

Flame War?

by jefw In reply to Well firstly FDISK is a D ...

First off, this isn't a flame war so just cool the jets.

It is Western Digital 1600 (WD1600JB-00GVA0)

Yes I actually looked at the jumper settings. (duh) I've ran the drive as a slave and as a master. I'm running it on a 3.2ghz Pent on a Abit mobo.

I did a lot of searching and found a lot of, "experts" they called themselves saying microsoft FDISK may not see these partitions and another so called, "expert" explained that fdisk through microsoft was different then fdisk Linux used. So I guess I should have posted here first to get the right information because they are apparently mistaken.

I don't want to read the contents of any partition it finds. NTFS or not. I just wanted to delete it.

I've used WD drives in the past, it's a pretty straight forward operation. (as you pointed out being able to do it in your sleep)

I'll follow up on the manfac website (again) on any other info regarding jumper settings. Not likely I'll find much more then before.

My ego is just fine thanks. I'm more worried about yours.

Collapse -

The WD's where one of the bunch that had a

by HAL 9000 Moderator In reply to Flame War?

Size Limiting Jumper so have a look for that here

http://tinyurl.com/2v69s8

All I'm saying is that you can use M$ FDISK to remove Non DOS partitions so if that isn't picking up the partition or is unable to remove it there is something else happening here.

Incidentally I don't claim to be any sort of expert I've just been working with computers long before there was a Microsoft or a PC for that matter so I've had a little bit of experience and I have removed Unix Partitions from HDD's using just the M$ 95 or 98 Boot Floppy so many times that I can not remember when I started using this method to wipe the partitions from a drive that came out of a different system and was being pushed into service in a Windows Environment for one of the staff members in their home.

Col

Collapse -

have you tried ...

by grassiap In reply to Can't access Linux Partit ...

partition magic, or download the last version of Gparted (GPL license).

both will enable you to reclaim the linux occupied space and either resize the windows partition or create a new partition that you'll be able to handle from windows.

You can also use the disk management console : right click on my computer icon then manage.

before doing all that I recommend you to take the time to make a restoration floppy in case there is a non windows boot manager. Playing with the partition table may corrupt the boot sector. This is not such big deal to fix but it may be painful...

HTH
Philippe

Collapse -

Gparted

by jefw In reply to have you tried ...

I tried Gparted and again it only recognized the partition and after deleting the partition it saw only 34mb's of a hardrive. I hoped that would be my answer as it searches many types of partitions.

Windows OS does not recognize Linux partitions. Microsoft would not allow such easy access.

Thanks for the advice. I think I will make a good paper weight out of it or see if it floats in the river. :)

Collapse -

This one has me puzzled

by grassiap In reply to Gparted

well this is not the core of your question, but there are a couple of windows "filesystem" driver that can handle several types of linux partitions (mostly ext2 and variants ext3 being backward compatible, the journalization not being handled in "windows mode")
http://www.fs-driver.org/

but if gparted and other linux utilities cannot handle it, it will not help you.

Then my 2 cents contribution would be to get down to the basics : jumper settings on the drive (as suggested in an other post), bios settings (maybe, just maybe, some CHS default bios settings overriden by windows ACPI), test the integrity of the partition tables (I had something somewhat similar one day where both copies of the partition table were inconsistent windows using one, linux finding it damaged and prefering to use the backup)
test the HDD in an other PC or in a usb enclosure ...

If (when) you manage to overcome this one I'd really like to hear about your fix.

Philippe

Collapse -

why is this hard?

by cls In reply to Can't access Linux Partit ...

Boot your favorite live Linux CD. damnsmalllinux, Knoppix, whatever. Get a root shell. Run cfdisk. Do whatever you need to do to the partition table. Write partition table to disk. Exit cfdisk.

If there is nothing on the drive you want to save, just **** the partition table away and start over. In your root shell, 'dd if=/dev/zero of=/dev/hda bs=512 count=1' Or you can wipe the whole drive by leaving off the count. And it might go faster with a large buffer size, bs=4096k

They actually *sell* programs to do that?

Collapse -

But that is just what isn't happening

by HAL 9000 Moderator In reply to why is this hard?

Boot & Nuke has supposedly been used to clean the drive and it's not able to overwrite this supposed partition. There has to be something else present that is causing the problem to occur.

About the only thing that I can think of is a Size Limiting Jumper which limits the size of the drive to somewhere around 40 GIG and just makes the rest of the drive unusable. Western Digital has had stuff like this for a long time now and it's the only thing that I can think of that could be causing this to happen short of a HDD fault.

Actually I suppose that the WD Testing Program has been run on this drive and that it's checked out as OK right?
I don't know if this will help but all of WD's down loadable software is here

http://tinyurl.com/drdml

Col

Back to Hardware Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums