Question

Locked

Can't connect to internet after resetting laptop to factory settings

By kaylise88 ·
Hello, everyone. I have a Sony Vaio VGN-NR220e laptop (Windows Vista). After resetting my laptop to factory settings, I can connect to my router, but I can't access the internet. All of my other devices can connect to the router and access the internet. I've tried the DNS flush cmd, Winsock reset, and ipv4 reset. My hard drive is said to be operating fine and is up to date in device manager. I've tried connecting the laptop to my phone's mobile hotspot. Although it was able to connect, I was still unable to connect to the internet. The proxy setting in Internet Explorer is unchecked, and a reset in the internet options did not help. Any suggestions will be greatly appreciated. Thanks.

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Laptop network adapter issue

by jlabadessa In reply to Can't connect to internet ...

Are you unable to connect via wired or wireless connection? When I have ran into this issue in the past, it is device driver related majority of the time. If you have not done so, I would access the Sony web site and download the LAN and WiFi adapter drivers for your exact laptop type/model. It would also not hurt to update BIOS, Chipset, etc. as these updates can impact hardware operation.

As a last resort, you can always purchase a cheap, USB WiFi adapter and get connected that way, however I suspect that you have a driver issue if neither wired or wireless adapters work. Good luck.

Collapse -

"Local Only" Access

by kaylise88 In reply to Laptop network adapter is ...

Neither works. I've also discovered that I have "local only" access. What can I do to change this? Thanks.

Collapse -

What you describe sounds like a DNS issue?

by jlabadessa In reply to "Local Only" Access

Are you able to PING another local device on network...like printer or another computer? If so, the network adapter has a good connection. Have you tried to specify Public DNS servers in your adapter IP setting...like 4.2.2.2 & 4.2.2.1 or the OpenDNS servers: 208.67.222.222 & 208.67.220.220. I would also try a tracert from a DOS command prompt to one of these external IPs. Does your router/firewall have a IP or MAC address filtering enabled? Also, if you take the laptop to another Public location, like a Panera Bread, local library, etc...are you able to connect? If so, then your issue is on your local router.

Back to Windows Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums