General discussion

Locked

Can't get router to play nice with IP MA

By mnsain ·
Ok guys, here's the deal. I got a branch office in Tucson, AZ connected to my office here in Phoenix. The connection is static 56k line with two Cisco 1602 routers. I have a Linux (RH6) server using IP Masquerading for Transparent Proxy (NAT). The Masq is set up to receive from all address and send to all addresses. (ipchains -A forward -i eth0 -j MASQ) The problem is, that from the routers, and ultimately the Tucson office, there is no route to the Internet. I can ping the private address for the Linux server, but not the public address. Nor can I ping any public address. The Linux server simply ignores packets from the router. Any ideas?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Can't get router to play nice with IP MA

by Igor Shulz In reply to Can't get router to play ...

I think you should set default gateway address (default route) in Cisco routers:
- router in Tuscon should have IP address of another router (address of its nearest to Tuscon interface) as default gateway
- router in Phoenix should have IP addressof your gate to internet (your Linux box?)as default gateway

Collapse -

Can't get router to play nice with IP MA

by mnsain In reply to Can't get router to play ...

The question was auto-closed by TechRepublic

Collapse -

Can't get router to play nice with IP MA

by randyarnold In reply to Can't get router to play ...

Look at the cisco in Tucson " show ip route" and see if the wan port of that router is the default gateway - it needs to be. The router in Phoenix nees to have the address of the "internal" network card on the masq box as it's default gateway.
On the masq box, be sure that it has a route to the local router "/sbin/route".
All client Pc's need to have thier local router as thier default gateway.

Randy

Collapse -

Can't get router to play nice with IP MA

by mnsain In reply to Can't get router to play ...

The question was auto-closed by TechRepublic

Collapse -

Can't get router to play nice with IP MA

by green In reply to Can't get router to play ...

First of all, NAT (in this context) is
Network Address Translation (and is the same as io masquerading), and has nothing to do with Transparent Proxy.
You have not described your setup much.
Let's assume you have router in Tuscon.
eth0 is local net with fake IPs (let's assume 192.168.1.0/24 subnet) and eth1 is interface to outer world.
you need to issue "ipchains -A forward -s 192.168.1.0/24 -d 0.0.0.0/0 -j MASQ"
this will enable IP masquerading for your local subnet.
Also make sure thatyou have default route on your linux box, that points to your Cisco router (through eth1 in assumed setup)
You can also obtain a lot of useful info from IP-Masquerade mini-HOWTO.

Collapse -

Can't get router to play nice with IP MA

by mnsain In reply to Can't get router to play ...

The question was auto-closed by TechRepublic

Collapse -

Can't get router to play nice with IP MA

by Linuxian In reply to Can't get router to play ...

I know this Q is old but, The 1602 should do NAT. What the Linux box?

Collapse -

Can't get router to play nice with IP MA

by mnsain In reply to Can't get router to play ...

The question was auto-closed by TechRepublic

Collapse -

Can't get router to play nice with IP MA

by mnsain In reply to Can't get router to play ...

This question was auto closed due to inactivity

Back to Linux Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums