General discussion

Locked

Can't join member server

By JDeez ·
I have a Windows 2000 server with AD and DNS all running smooth. However, I have a second server that I am try to add as a BDC. When I run DCPROMO I can get through the wizard but at the end it says "The specific domain does not exist or could notbe contacted". It will not allows the machine to finish DCPROM and be promoted. This is a friends business and I also noticed that the PDC has a "server.local" extention. Anyone know what the .local extention does and how I can get this second server to join as a BDC. I was able to join it as you would a workstation. Putting it into the domain via the properties of my computer.

Any idea? Thanks in advance.

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by sanboitran In reply to Can't join member server

.local extention is the default domain of your DNS domain.

Collapse -

So that wouldn't make a difference

by JDeez In reply to

Thanks. So I guess I can rule that out as the reason for the second server not joining via DCPROMO. I check all the knowledge base entries in the Microsoft knowledge base that relate to my issue icluding Q283133 & Q228328. Got any ideas?

Collapse -

Start at the begining...

by Ken Howard In reply to Can't join member server

First thing I would check is connectivity. Can you ping the server by ip address. Then I would check for name resolution - can you ping it by name, if so then what is the FQDN (fully qualified domain name) of the forest root domain controller. What does NSLookup reveal - are you able to access a DNS server and can it resolve to the EXACT name you are using in the DCPROMO process.

The error you received feels like connectivity or a misnamed domain. If the FQDN of the first DC is something like Server.Domain.Local, then the name of the domain is "Domain.Local".

Best of luck...

Collapse -

I think your on to something

by JDeez In reply to Start at the begining...

I am able to ping the PDC (by the IP and what I believe is the domain name) and I can even join the second server into the domain through the "Network Identifications" tab within the properties of "My Computer". However, whe I do put the machine into the domain manually I enter what I believe is the correct domain name it resolves to another name with the .local extention. The same thing happens when I run DCPROMO, the name resolves to the .local extention.

What do you think? Any ideas on how to resolve this?

Collapse -

Netbios domain name

by Ken Howard In reply to I think your on to someth ...

We need to get the definitive names of the domain and ensure that they are correctly configured inside of DNS. Open AD Users and Computers right click on the domain name and check the properties. The pre-2000 name is the Netbios name for the domain and the domain name you clicked is the DNS name. Write these down and ensure that there is not some sort of conflict with the Netbios name when you run DCPROMO. The DNS name is the name you need to use to promo the secondary DC (it is NOT a BDC - no such thing in a native 2k domain and if it is not native - ie. you have NT 4.0 BDC's - it is still not a BDC it is simply a DC). If it starts to resolve to the Netbios name that is OK unless it cannot find it. If this is the case, check WINS and esp.DNS to ensure that the domain names are accurate inside of DNS and that you have the appropriate SVR records for the DC's.

Hope this helps...

Back to IT Employment Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums