Our forums are currently in maintenance mode and the ability to post is disabled. We will be back up and running as soon as possible. Thanks for your patience!



Can't map a drive via VPN on Windows 7, CAN connect to VPN though?

By zwa233 ·
Hello, I'm fairly new to VPN but I am having a lot of difficulty. I am trying to access my university server folder via VPN. I have been giving the information and access and am able to login and connect via the Cisco VPN client and it says Connected to "University". Then when I go to Map Network Drive and type in \\Server\Folder it gives me the error "Windows cannot access \\Server\Folder Check the spelling of the name. Otherwise, there might be a problem with your network." and I can click Diagnose, but that never does anything.

I am on Windows 7 Professional. I have tried turning the Windows Firewall on and off, as well as trying to configure it to allow VPN. I thought maybe the problem was a program called PeerBlock but I've since disabled it and nothing has changed.

I've even had an IT guy from the University remotely access my computer use his own login information to try to do this and he could not get it to work either. So it does not seem to be a problem of username access or restriction, but some sort of network problem that I can not figure out.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Couple of things to check

by scndtnr In reply to Can't map a drive via VPN ...

1. In the transport settings for your VPN connection (right click on the connection entry, select Modify, click on Transport), verify that the Enable Transparent Tunneling box is checked, and IPSec over UDP (NAT/PAT) is selected.
2. See if your university's IT staff will give you the IP address of the server, then map your drive as \\\folder.

The fact that the name of the server is not being recognized points to a DNS problem.

Collapse -

Reponse To Answer

by zwa233 In reply to Couple of things to check

1. All good there.
2. I have the IP that is given as the "host" of the VPN connection, which I assume is the server? I can run cmd and ping that IP and get replies, but if I try mapping the drive such as "\\HOSTIP\Folder" then I get the same error.

Collapse -

The host IP is not

by scndtnr In reply to Can't map a drive via VPN ...

...the IP address of the server; it's the external IP address of the Cisco device that accepts and defines the VPN connection. You'll need to get the server's internal IP address to test the drive mapping when the VPN is established.

You might be better off getting the university's 2nd or 3rd level tech support involved; seems to me that the tech that helped you in the first instance did not go far enough with this issue.

One final thing to check: when the VPN is established, what's the network type that is displayed in the Network and Sharing Center on your computer? If it's "Public", try changing it to "Work"; this may change some network discovery settings and allow you to map a drive using the server name.

Collapse -

Reponse To Answer

by zwa233 In reply to The host IP is not

Ok, I will contact IT again and try to get the server IP.

I was on the "Home" network type - I switched it to "Work" but nothing changed.

Collapse -

Binding order DNS issue

by MNTechGuy In reply to Can't map a drive via VPN ...

In the Network and Sharing Center, under Advanced->Advanced Settings, make sure that the Network Adapter corresponding to the Cisco VPN Client is at the top of the list in the Bindings, otherwise it is likely attempting to resolve your server name at your ISP rather than your University. One other gotcha is not appending the domain suffix at the end of the server name \\\folder when your computer isn't actually a member of the domain. You can also troubleshoot name resolution issues quickly by using NSLookup from the command prompt.

Collapse -

Reponse To Answer

by zwa233 In reply to Binding order DNS issue

How do you make the network adapter top at the list of the bindings?

I did the NSLookup and got an IP and server address, but using this IP to map the drive does not work. Pinging this IP also does not work, it says "Server failed" or "non-existent domain".
I'm not sure what the domain is to map with like you said in \\

Collapse -

agree with ll the above

by markp24 In reply to Can't map a drive via VPN ...

with VPN sometime DNS doesn lot work and you have to map the drive via IP address (ie \\ipaddess\sharename. But thats because DNS is not setup with the vpn network as needed,

Collapse -

Simple fix from the old school

by RechTepublic In reply to Can't map a drive via VPN ...

Edit the HOSTS and LMHOSTS files on the computer to allow local resolution of the remote server names. The key is remembering that you did this years from now when IP addresses and/or computers names change. The files are in Windows\System32\Drivers\Etc. Make sure that these files do NOT have a file extension when you are done. Run "ipconfig /flushdns" and "nbtstat -RR" to clear the old caches and you should be able to ping and map remote servers by name. Good luck!

Collapse -

Reponse To Answer

by zwa233 In reply to Simple fix from the old s ...

Didn't work, but I'm not entirely sure I did it right either. I still can't ping by the server IP.

Collapse -

Try this:

by scndtnr In reply to Can't map a drive via VPN ...

Establish the VPN connection
Open Network and Sharing Center
Click on Change Adapter Settings
Right-click on Cisco VPN adapter, select properties
Click on Internet Protocol Version 4
Click on Properties
Click on Advanced
Click on DNS tab
Enable the "Append these DNS suffixes (in order):"
Click on Add
type in the domain name (like
Click on OK, OK, etc.

Try to map the drive, or from a command prompt, see if you can ping the server by name.

Related Discussions

Related Forums