Can't print to shared printer over LAN

By fishjosc ·
I have a small LAN (2 PCs running XP) and have been trying, with the help of others who are more knowledgable, to be able to print to the printer on another PC. I can access the internet from the second PC, but can't access the network. I get message saying I may not have permission to use this resource and to contact the administrator of the server. I am the only administrator for both PCs; how could I not have permission to access this resource? Obviously I have the printer set up for sharing and I can see PC#2 over the network but get the same error message as when trying to see the LAN from PC#2, except "Network path was not found".
I am getting tired of using a floppy from PC#2 over on PC#1 in order to print.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Lets see...

by jtakiwi In reply to Can't print to shared pri ...

The basics: Can you ping, by Ip address from one pc to the other and vice versa? If not, are both computers on the same subnet? As in pc1 is and pc2 is192.168.0.3/ for instance? As far as accessing shared resources, do they both have the same workgroup name? Do they both have the guest account enabled? If yes to these, then, are you using consistent local user accounts and passwords? Now, if you had to make workgroup or network address changes, just wait, the browse list can take a while (20 minutes or more) to refresh.

Collapse -

please reply me an answer

by blue_hopper In reply to Lets see...

Hello, my name is Zeljko (that would be something like Wishy in English) and I'm from Serbia. I am 27 and got a job few months ago- LAN Administrator of a do you name it...doesn't matter, something with finances and books...anyway, it is 16 PCs LAN, XP SP2. I have a similar problem like the guy you have answered to already, and here it is:
16 machines, all of them in the same workgroup, the same subnet, every machine has its own name and IP adress. There are 6 printers there, and I have focused just on two of them. 14 PCs perfectly recognize each others' resources and files, and I have problem with just two of them: they both see all other computers and are able to print on one printer, but not on the other. When I try to add the printer they can not reach, I get the message saying "Active Directory Service Is Not Running". Can you tell me your opinion, please?

Thank you in advance,
Dr Pauk

Collapse -

RE: domain users can't print to network attached printer but admins can.

by mwilsonkim In reply to Lets see...

I had the same problem (twice actually, but was able to solve it by following the instructions of a thread at, plus another thing.
Basic Gist:

(assuming the computer with the printer attached is registered in the domain and you can print from locally from that computer, and the printer is added to the active directory.)

1. Make sure on the local computer that the permissions are correct for the printer, and also the spool directory (windows/system32/spool). For me, I'd have thought that the permissions would include domain users, etc since the computer was in the domain, but they were there. So i added them, and then made sure all the files in the underlying directories were the same permission.

2. After saving the permissions, I was able to add the printer for more user from the active directory (domain user, not domain admin). But then for some reason I couldn't add more. (ARG!)

3. After playing with it more, I tried restarting the print spooler service on the local machine (run-->services.msc-->print Spooler (restart)).

4. After that I was able to add all the other users.

I suppose that after changing the permissions, i could have restarted the machine and that would have worked too. Since I haven't had this permission problem occur in all my implementations, I'm guessing that the way I added the computer to the domain didn't do everything it was supposed to (I think i just went to My Computer (properties), and joined the domain there... but not sure).

Anyhoo, after that, i've had no problem accessing the printer. Good luck all!

Michael Kim

Related Discussions

Related Forums