Question

Locked

Can't ssh into server attached to a Cisco Pix 501 via VPN

By isster ·
I know what I am doing should be simple and a popular setup. I have a cisco pix 501 that I can successfully vpn into. The problem is I can't access any of the servers behind the cisco pix via ssh. I am a newbie to this and I just can't figure it out. Maybe someone can spot it quickly and call me a dummy.

The ton's of posts out there basically say the following:
1) Tell router to not use NAT for vpn users

access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.224
nat (inside) 0 access-list inside_outbound_nat0_acl

2) specify these commands

isakmp identity address
isakmp nat-traversal 20


PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxx encrypted
passwd xxxxx encrypted
hostname pixfirewall
domain-name DOMAIN
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list VPNGROUP_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 10.10.10.0 255.255.255.224
access-list outside_cryptomap_dyn_20 permit ip any 10.10.10.0 255.255.255.224
pager lines 40
logging on
logging timestamp
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN_POOL 10.10.10.10-10.10.10.20
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http xxx.xxx.xxx.xxx 255.255.255.255 outside
http xxx.xxx.xxx.xxx 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPNGROUP address-pool VPN_POOL
vpngroup VPNGROUP default-domain DOMAIN
vpngroup VPNGROUP split-tunnel VPNGROUP_splitTunnelAcl
vpngroup VPNGROUP idle-time 1800
vpngroup VPNGROUP password ********
console timeout 0
dhcpd address 192.168.1.2-192.168.1.33 inside
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Solved

by isster In reply to Can't ssh into server att ...

Turned out that I was using the same subnet (192.168.1.x) as the cisco router. My local computer didn't know where to send the packets. All I had to do is change the subnet on the cisco router to something else.

Back to Networks Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums