Question

  • Creator
    Topic
  • #4151861

    Can’t switch languages

    Locked

    by doniel ·

    After checking out some results of a search for solutions to the problem in the subject of this post, I realized that I’m not going to find an answer that way. What’s happening is too weird.
    I’ve had a second language (herein referred to as Lang. 2) installed in various versions of Windows for many years, incl. Windows 11 for the last 8 months. My marvelous keyboard, which came with my Blackship 486/25 back in 1991, doesn’t have a Windows key (that key didn’t exist yet). I can switch to Lang. 2 using Alt-Shift, but I normally just click on the language indicator in the system tray area. Today, when I clicked on the icon and then on Lang. 2, the indicator changed to Lang. 2, but my typing produced English letters.
    Here’s the weird symptom. I checked all the Lang. 2 letters and two of them displayed as the correct Lang. 2 characters. The rest all showed as English.
    I tried uninstalling the Lang. 2 pack and reinstalling it.
    I rebooted.
    And although I knew it wouldn’t help, I plugged the keyboard into a different USB port. (Yes, I know that there was no USB in 1991. When the serial connector – or more likely, the port – stopped working, I bought a serial to USB adapter.)

All Answers

  • Author
    Replies
    • #4151878
      Avatar photo

      Re: switch languages

      by kees_b ·

      In reply to Can’t switch languages

      It’s a little bit unclear what you mean with “languages”.

      After all, English and French are different languages, but have the same character set (1252, West European Windows). Russian and English are different languages also, but they have different characters.

      The language you specify in the icon, indeed, defines the keyboard lay-out, for example the difference between querty and azerty, or a keyboard with build in keys for letters with diacritic marks and how a double quote works (as a quote or as start of a diacritic umloat).

      And, of course, there is the language Windows uses in the UI, saying Folder (English) or Dossier (French).

      I’d start with doing a System Restore back to when it still worked. Or, even better, back to an image backup of your system disk that worked correctly.

      Also, just as an experiment, try another keyboard.

      • #4151980

        Good idea

        by doniel ·

        In reply to Re: switch languages

        Thank you, kees-b. Restoring the image I did this morning should have occurred to me. If the problem already existed at the time of that backup, I’ll have to go to Sunday night’s backup.
        By the way, I meant a completely different character set, such as Greek or Chinese.
        Once I’m rebooting for the restore, I’ll first check if the problem’s also in Windows 10, which I haven’t booted into in months. If it is, that would indicate a more pervasive problem which a Windows 11 restore likely wouldn’t solve.
        I’ll post back here.

    • #4152035

      Alternate languages

      by jd7180669 ·

      In reply to Can’t switch languages

      It sounds like you’re encountering a perplexing issue with your language settings and keyboard input on Windows 11. While I might not have all the specifics about your setup, I can offer some troubleshooting steps that could potentially help you resolve the problem:

      Check Keyboard Settings:
      Make sure that your keyboard layout is correctly set to the language you want to use. Sometimes, the keyboard layout settings might get changed inadvertently. To check this:

      Go to “Settings” > “Time & Language” > “Language.”
      Under the “Preferred languages” section, select your Lang. 2 and ensure that it’s set as the default language.
      Click on “Options” and ensure that the correct keyboard layout is selected for your Lang. 2.
      Keyboard Shortcuts:
      It’s possible that keyboard shortcuts have been inadvertently changed or interfered with. Double-check your keyboard shortcut settings for language switching:

      Go to “Settings” > “Time & Language” > “Language.”
      Under “Language preferences,” click on “Spelling, typing & keyboard settings.”
      Ensure that the shortcuts for switching between input languages are set correctly.
      Check for Updates:
      Sometimes, system updates can impact keyboard and language settings. Make sure that your Windows 11 is up-to-date by going to “Settings” > “Windows Update” and checking for updates.

      Remove and Re-Add Language:
      Since you mentioned that you’ve tried reinstalling the Lang. 2 pack, consider removing it completely and then adding it back:

      Go to “Settings” > “Time & Language” > “Language.”
      Click on Lang. 2 and then click “Remove.”
      Restart your computer.
      Go back to the language settings and add Lang. 2 again.
      Check Compatibility:
      Older hardware might sometimes face compatibility issues with newer operating systems. While Windows 11 aims to be backward compatible, there could be certain compatibility glitches. Make sure you’re using the most recent drivers for your keyboard and any relevant hardware.

      Keyboard Hardware and Adapter:
      While you’ve mentioned using an adapter, sometimes adapter-related issues can cause unexpected behavior. Try connecting the keyboard directly to the original port it was designed for (serial port, if available) to see if the behavior changes.

      Reset Keyboard Settings:
      If the issue persists, you could try resetting the keyboard settings to their default:

      Go to “Settings” > “Time & Language” > “Languag

      • #4152142

        Thank you, jd7180669

        by doniel ·

        In reply to Alternate languages

        I appreciate the time you took to offer all those suggestions. Unfortunately, I only saw your post after doing a restore. Lang. 2 worked fine in Windows 10, so it was clear that it wasn’t a keyboard problem and that it was a Windows 11 issue.
        I did have to do 2 restores. The problem was already there in the most recent backup, so I restored Sunday night’s backup. And that did the trick.
        I sure hope it doesn’t crop up again.
        Thank you both for your help.

        • #4152577

          What I feared came to pass

          by doniel ·

          In reply to Thank you, jd7180669

          I alluded to it at the end of my last post. I was afraid that whatever caused the loss of Lang. 2 to begin with would do so again after the restore. It did.
          Your suggestions didn’t help, jd7180669.

    • #4152599

      switch languages

      by imranwaheed143 ·

      In reply to Can’t switch languages

      Ensure that your Windows 11 OS is up-to-date. Sometimes, bugs related to language packs or keyboard functionalities might be resolved in newer updates. After reinstalling the Lang. 2 pack, ensure you’ve set it as the default input method. Sometimes, settings can be overridden or not saved correctly. It’s possible that while Lang. 2 is selected, the keyboard layout associated with it is still English. Navigate to the language settings and ensure that the correct keyboard layout is selected for Lang. 2. If you have third-party keyboard or macro software installed, it may be interfering with the input. Temporarily disabling or uninstalling such software can help in identifying the culprit. As a diagnostic tool, activate the on-screen keyboard (OSK) and switch to Lang. 2. If the OSK displays and types the correct characters, it can indicate an issue localized to your physical keyboard or its configuration.

      • #4152623

        Eureka!

        by doniel ·

        In reply to switch languages

        Thank you, imranwaheed143! When I got to the part about third-party keyboard software, it suddenly clicked. I just installed an anti-keystroke logging program. I didn’t read any further. I clicked on its icon, disabled protection, and my typing produced Lang. 2.
        A pity I didn’t think of it myself, but I’m so grateful to you for pointing me to the solution.

    • #4157079

      check the settings and any updates in the device

      by Harisamer214 ·

      In reply to Can’t switch languages

      Here are a few things you can try:

      1. Make sure that the language pack for Lang. 2 is installed correctly. You can check this by going to Settings > Time & language > Language & region. Under Preferred languages, make sure that Lang. 2 is listed and that it is set as the Default language.
      2. Try resetting the keyboard to its default settings. You can do this by going to Settings > Devices > Keyboard > Advanced keyboard settings. Under Reset keyboard, click Reset.
      3. Try updating the keyboard drivers. You can do this by going to Device Manager and expanding the Keyboards category. Right-click on your keyboard and select Update driver software.
      4. If you’re still having trouble, you can try contacting Microsoft support for help.
      I hope this helps!

Viewing 3 reply threads