Question

  • Creator
    Topic
  • #2151574

    Can’t update from XP SP2 t o SP3

    Locked

    by raytalbot ·

    I have Windows XP Home with SP2 installed. I have tried twice to update to SP3 and both times it has failed. I have tried via the windows update method and also downloading SP3 from your site and installing it. I am presented with a small window telling me just “Cannot update” and nothing else or any reason why it can’t continue. Are anyone else having this problem?
    Thanks for your time

    yours Ray

All Answers

  • Author
    Replies
    • #2926003

      Clarifications

      by raytalbot ·

      In reply to Can’t update from XP SP2 t o SP3

      Clarifications

    • #2926001

      Had the same problem 2 days ago

      by j_a_merhi ·

      In reply to Can’t update from XP SP2 t o SP3

      after many tries (more than 20), managed to download it directly from the updating site, but if you can’t, all you can do is to download the ISO from Windows downloads Center and to install it, the add is http://www.microsoft.com/downloads/details.aspx?FamilyID=2fcde6ce-b5fb-4488-8c50-fe22559d164e&DisplayLang=en

      good luck

    • #2925998

      Maybe you’ve already got SP3 installed ??!! …

      by older mycroft ·

      In reply to Can’t update from XP SP2 t o SP3

      Microsoft has already rolled this Service Pack 3 out as a Windows Update.

      I know this because I have been fighting with my Update system (notify but DO NOT download) for the last 36 hours: M$ continues to try and sneak SP3 past me.

      Open your ‘Run’ box, type [u]cmd[/u] and hit ENTER, type [u]winver[/u] and hit ENTER. (Type [u]exit[/u] and ENTER to close the command line box)

      Check what Service Pack is listed in the results box that appears. 😉

      • #2924934

        OM you need to install some M$ provided software

        by oh smeg ·

        In reply to Maybe you’ve already got SP3 installed ??!! …

        To prevent either the Windows or Microsoft Update Service Installing SP3.

        It’s here

        http://tinyurl.com/2tadkt

        It’s called the Windows Service Pack Blocker Tool but I don’t know of a way to be notified that SP3 is available and to block it at the same time.

        Col

    • #2925994

      I had a similar issue…

      by captbilly1eye ·

      In reply to Can’t update from XP SP2 t o SP3

      in both cases that I encountered, an ‘Access Denied’ error came up about half-way through the installation and then a roll-back occurred. Both were resolved by installing [b]SubInACL[/b] and running a script as prescribed in this article: http://tinyurl.com/5nacly

      I suspect that spyware or a virus had removed administrator permissions to parts of the registry.

      You will want to use this installer:
      http://tinyurl.com/4qvth5

      Let us know what happens.

    • #2924933

      XP SP3 has been available from both the

      by oh smeg ·

      In reply to Can’t update from XP SP2 t o SP3

      Windows Update Site and the Microsoft Update Site since the 19-6-2008 so if you have Automatic Updates turned on it’s already installed. It would have appeared as a download of about 66 MEG size last month.

      You can check this by opening My Computer left clicking on Help and then About Windows. If it shown the following

      Version 5.1 [build 2600 xpsp 080413.2111: Service Pack 3]

      You have service Pack 3 Installed already. Please Note the codes may be slightly different as that one comes off a XP Pro system and Home is a bit different.

      The only times that I have seen the [b]Cannot Update[/b] message is when the item has been installed already or when WGA is insisting that the Copy or more correctly the Product Key for XP is a Pirate Copy. If the latter is the case here you need to contact your System Maker for a new Product Key to bring XP back to being accepted as Legit by Windows Genuine Advantage.

      Col

      • #2832782

        Not always

        by justagallopin ·

        In reply to XP SP3 has been available from both the

        Registry problems after a virus/malware corruption can also prevent turning on auto updates, prevent direct download from win update site and prevent even a IT version of sp3 being installed directly. Correcting registry/permissions can be very time consuming. I had to check the ImagePath Value in the Registry key HKLM\SYSTEM\CurrentControlSet\Services\wuauserv and verify it is “%systemroot%\system32\svchost.exe -k netsvcs” and not a fake path like %fystemroot%\.. netsvcs
        Registry entry was wrong for AU as well as BITS. Fix ownership first, correct incorrect values and save. All works well after this.

        Old post, new problem and now with controllers for sata devices that XP install disc won’t recognize disc and who has floppy? If Bios won’t cooperate, time to slip stream. XP is getting harder to work (more time consuming) on as it gets older.

Viewing 4 reply threads