Question

Locked

CD Drive won't show up in "My Computer". Why?

By zack247 ·
i am building a custom compter, and i had put in some CD Drives, but they dont show up in my computer and i don't know why! they show up in the bios, so i know they are functional, but why aren't they working right? i can't upgrade from win98 because my cd drives aren't working, and i cant figure out why! why aren't they? please help!

This conversation is currently closed to new comments.

23 total posts (Page 1 of 3)   01 | 02 | 03   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Well for starters what OS are you using here?

by OH Smeg In reply to CD Drive won't show up in ...

If it's some form of Windows look in the Device Manager Window and see what is there. Any devices with a Yellow Triangle and black Exclamation Mark through them do not have the Drivers installed so you'll need to install the required Drivers.

If the Optical Drives are showing in the BIOS correctly and you are using 98 I would be guessing on a new build that the Chip Set Drivers for the M'Board need installing and because of how old 98 is it doesn't support that Chip Set or even any sort of Default Drivers to get it part way working.

Anyway how did you get 98 onto this system?

Col

Collapse -

RE: Well for starters what OS are you using here?

by zack247 In reply to Well for starters what OS ...

i am using windows 98. for all of the computers i build, i start with win98, just in case the computer hasn't been configured for winxp yet. then, when its all functional, i upgrade to winxp. i have tried five cd drives, and not a single one of them have worked. this is the same computer as mentioned in my other forum question. it is now working, the chip was burnt out, and it was a stand-up chip, so i couldnt figure out if it was burnt ut or not.i switched the chip, and it worked. but i am only running win98. is there any compatibility issues with something? here is a list of parts that are in it:

-asus P28-VE motherboard
-mitsumi cd rom drive model no. CRMC-FX320S
-LG 12X/8X/32X speed ide CD-RW drive product no. 06P5160 from IBM computer
-Intel Celeron
-256mb SDRAM
-hdd:Fujitsu model no. MPD3108AT
PCI Cards:
-Creative Labs sound card model no. CT4740
-Modem: barcode 9412504W
-3Com Etherlink XL 3C900-TPO internet card
PSU: Enermax 12v ATX PSU model no. EG365P-VE

Collapse -

I'm getting a queasy feeling about this ...

by OldER Mycroft In reply to RE: Well for starters wha ...

You still haven't explained how you managed to install W98 if the optical drive was not functional.

Also, why this incessant unending baseline where you start with W98 then upgrade?

Sorry but I've got to ask: are you upgrading to a Genuine Windows XP or have you got some sort of scammed pirate upgrade running here?

*I'd also like to know what you meant by "a stand-up chip"?

Also, a 10.8GB HDD won't have much space left once you've installed 2.5GB+ of Windows XP.


Edit for *

Collapse -

let me explain...

by zack247 In reply to I'm getting a queasy feel ...

okay. the stand up chip im talking about is one of the celerons that plug into the brown slot. here is a pic: http://www.hwinfo.sk/images/CPU/Intel/IntelCeleron300A.jpg
it looks something like this. im not exactly sure, because i have never been curious enough to take off the heatsink.

and, i use a different computer to install win98.

no, i use a legit copy of windows xp

i start with win98, because if the computer has never run winxp before, then it tells me it has all of these problems with the os and all that. so i start with win98 just in case.

does that explain it all?

Collapse -

Wow ! - It's been quite a while ...

by OldER Mycroft In reply to let me explain...

Since I've seen that particular CPU architecture.

Collapse -

OK I'm not really sure what is happening here either

by OH Smeg In reply to RE: Well for starters wha ...

If the Optical Drive isn't working how did you install 98?

Probably more importantly ASUS doesn't list a P28-VE M'Board or anything at all under the P28 Family they do have a P2B-VM model which uses a Socket 370 M'Board is this the one that you are using here?

Col

Collapse -

yes, the P2B-VE motherboard, i misread it

by zack247 In reply to OK I'm not really sure wh ...

i misread the motherboard. it says P2B-VE. not P28-VE.

but yes that is the one.

heres a pic of the inside of my computer. you will see the chip im talking about
http://www.mediafire.com/imageview.php?quickkey=tbymztgny5c&thumb=4

a pic of the motherboard:
http://www.gearxs.com/gearxs/images/p2b.jpg

i used a different computer to install win98.

Collapse -

OK that is a Slot 1 CPU and replaced the original Pentiums

by OH Smeg In reply to yes, the P2B-VE motherboa ...

Intel won a court case over AMD which has caused AMD to develop it's own Sockets and no longer supply replacement CPU's to fit on Intel M'Boards.

If these systems have not previously run XP they may very well not be compatible with XP, M$ used to have a XP Compatibility Tester though I can not find it on the M$ site now but I may be looking in the wrong place.

Quite a lot of these Slot 1 M'Boards where not XP compatible because of the way that ASUS incorporated the Intel Chip Sets on their M'Boards so that may very well be the problem here.

If you have a XP compatibility Tester I would suggest running it on the System but if you don't your only option is attempting to load XP from a XP Install Disc and not from within Windows which doesn't work anyway.

Set the BIOS to boot off the Optical Drive and insert the Windows XP Install Disc and when prompted to Press Any Key to Boot of CD press any key and follow the prompts.

If the system can not find a HDD you need to press the F6 Key when the first blue screen appears and when prompted insert a Floppy with the Chip Set Driver copied to it's root.

Or you can make your own Slipstreamed Install Disc for XP by using a product like nLite available here

http://www.nliteos.com/download.html

Just be sure to read the directions for use here

http://www.nliteos.com/guides.html

Col

Collapse -

RE: Slot 1 CPU

by zack247 In reply to OK that is a Slot 1 CPU a ...

but the optical drives dont work. and i have a computer with the same celeron type. its a dell, and its running xp like never before. but the reason i started this topic is because i was hoping one of you professionals could help me figure out what was wrong with the cd drives. i have replaced the ide(like 5 times) tried different power cables, and ive tried 3 different optical drives! i don't know what's wrong, and that's why i started this topic

Collapse -

So the Dell that you have has the exact same M'Board does it?

by OH Smeg In reply to RE: Slot 1 CPU

The problem here is with Second Hand Parts that you are using it is possible that something has failed. Did it cross your mind that maybe the M'Board was the issue here?

The IDE Controller on the M'Board can and does fail which in most places renders the M'Board unusable.

Try this to see if it is the IDE Controller on the M'Board.

Disconnect the HDD and the Optical Drive Data Leads from the M'Board. Disconnect both Optical Drives and with another Known Good one set to Master plug in a Data lead to the End Connector and then plug that into the M'Board where the HDD was plugged into.

Place a Boot Disc into the Optical Drive and start the system. If the Optical Drive now works power down and unplug that Optical Drive and plug the IDE Data Lead into the Master that is fitted tot he case. Power up again and insert a Boot Disc into the Optical Drive. If that works now power down and plug in the second Optical Drive and repeat the Process. If it still works power down and remove the Data Lead from the M'Board and replace it into it's original Socket and plug in the HDD where it originally was plugged in.

However if the Optical Drives do not work after they are both plugged into the same Data Lead power down and check the Jumpers on the Back of the Optical Drives. The one on the end of the cable needs to be set to master and the one connected to the Middle connector needs to be set to Slave. With these old M'Boards and Data Leads the CS Cable Select Option may not be supported so don't attempt to use it.

Also the 3 different Optical Drives that you have tried do you know if they actually work?

When you are reusing old equipment you need to test and retest everything so that when you strike a problem you have some idea what works and what doesn't. If you just throw bits together and hope for the best you often will be disappointed.

Here you could have a mess of failed Optical Drives or a Dead IDE Chanel on a M'Board or a Dead Data Lead. Without knowing what was tested as working I would guess that first the Data Lead should be replaced with a Known Good one and if that doesn't work then the M'Board.

Col

Back to Hardware Forum
23 total posts (Page 1 of 3)   01 | 02 | 03   Next

Related Discussions

Related Forums