CD-ROM, external USB Drives are dead, configuration in registry damaged

By pentrex ·
I have a desktop OS XP Professionaland and have a problem with the CD-ROM. The CD-ROM is dead. Device Manager gives the message:

Windows cannot start this device because its configuration information [in the registry]is incomplete or damaged. .

Deleting the drive and rebooting have not fixed the problem.

The same message is displayed when I plug in any external CD-ROMs through the USB port.

There is no way to run the installation disk to fix the problem.

How this problem can be fixed if the main input to the OS is not functioning? How to fix the damaged registry the message is refferring to?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Booting directly from OS disk? Safe mode?

by TobiF In reply to CD-ROM, external USB Driv ...

Have you tried booting directly from the installation disk, thus relying more on BIOS, rather than funny parameters deep in the registry?

Also try booting windows in safe mode, where much fewer drivers and programs are loaded.

- Put the installation disk in another computer and share this drive over your lan...
- Using another computer, copy the disk to a USB device (flash or hdd)

Collapse -

And make a visit to the BIOS settings at startup

by TobiF In reply to Booting directly from OS ...

You may want to adjust boot order etc. Just remember to save your settings upon exit.

Collapse -

I will try

by pentrex In reply to And make a visit to the B ...

What key do I need to press to get to the BIOS setup? Safe Mode? (as I tried all)


Collapse -

RE What key do I need to press to get to the BIOS setup?

by OH Smeg Moderator In reply to I will try

This depends on your computer but it is always listed on the POST Screen generally in the lower left hand corner of the screen.

Collapse -


by TobiF In reply to I will try

F8 is used to choose boot options for windows. Here you may select to start windows normally, in safe mode etc.

Something in my memory talks about F5 for some boot options, but don't know, really.

Ohh, somewhere I've seen F11 during the boot selection to enter into the windows recovery manager, but I think this is specific to the OEM vendor.

However, in order to reach BIOS setup, you need to keep a specific key pressed a bit earlier, namely at the same time you may hear a happy single beep, which confirms that the POST (self test) went well.

I have seen ESC, F2 and F10 being used for this, but could of course be almost any other key. The very first information the BIOS writes to the screen usually says something like "Press XX to enter BIOS setup". Watch for this just when the screen comes on. But when you have had time to read it, it's already too late, so you need to restart the computer and try again :)

Collapse -

it's fixed

by pentrex In reply to And make a visit to the B ...

I followed what you recommended: changed the boot order in BIOS and was able to reinstall Windowss (Repair faild as the setup all the time was asking for the SP which it for some reason couldn't find on the installation disk).

Now the CD ROM is OK . However now I got a problem with the Microsoft. Right after the installation, M-soft instantly let me know that I need to register my OS. The problem is that I lost my product key long time ago and to restore it will take a lot of time and efforts.

But anyway thanks a lot, you headed me to the right direction.

Collapse -

From technical to administrative problem :)

by TobiF In reply to it's fixed

Good to hear. Good luck with the activation.

Collapse -

Well assuming here that you mean that you need to Activate Windows

by OH Smeg Moderator In reply to it's fixed

And you didn't use the Install Disc that came with the system it's not a major problem provided that you used the Product Key on the COA stuck onto the outside of the case all you need do is click on the Activate Now Tab and let it activate.

If you didn't use the Product Key on the COA M$ Sticker on the outside of the case you can change it with a product Like Key Finder available free here


The Product Key is a 25 Digit Alpha Numeric String that consists of 5 Groups of 5 characters. Then activate the product.


Collapse -

tried to run but the result still the same

by pentrex In reply to Well assuming here that y ...

Thanks. I tried. The magicjelly gave me a number but M-soft rejected it too. Tried to call to my vendor where I acquired my PC from, but this company doesn't exist anymore. Really have a vague idea what to do next and where to get the COA or the product key the M-soft requires for the registering the OS.

Collapse -

Well if there is no COA on the case

by OH Smeg Moderator In reply to tried to run but the res ...

That's not a good sign. Many small shops here used to buy the M$ Action Pack and then load systems that they sold with the Volume License Stuff from the Action Pack.

A very cheap OS and Software for Shops and also highly illegal. Not to mention none of them stayed in Business for any length of time and has M$ Legal chasing the Principals even now.

But if you have a M$ Install Disc you can just ring the M$ help Line and quote the Number off the Inner Ring of the Disc and they will issue you a new product key.


Related Discussions

Related Forums