CD Rom not showing in My Computer

By tstrauss ·
I work at a public library, and the person who was the tech person deleted the CD Drive icon from the My Computer window and from Explorer on all of our public computers (the ones that the patrons use). I am not sure how or why she did this.

Besides that the CD drives work normally and their contents can be accessed if I enter drive's letter in explorer.

Does anyone know how I can get the icon back so that the CD drives will be easier for our patrons to access?


P.S. The issue is on both XP and 2000 computers.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

group policy

by operator1 In reply to CD Rom not showing in My ...

Sounds like drive has been hidden with group policy settings.You might need to have admin privileges to do this.
go to start ->run -> type mmc.
if you can run it great if you dont bad.
You will then need admin account.
Anyway once you can get admin rights on the system run this mmc go to file menu
->add/remove snap-in and then add group policy object.Browse to this key
Local computer policy\User Configuration\Administartive templates\windows components\windows explorer.
You will see on the right pane HIDE THESE SPECIFIC DRIVE in MY COMPUTER.
If you can go inside and remove your cd from the list great.

Collapse -

tried but...

by tstrauss In reply to group policy

Thanks so much for the reply. I did exactly as you said, but when I got to windows explorer, it shows that "Hide These Specific Drives in My Computer" is "Not Configured." Just in case, I enabled it and set it so nothing was restricted. But, that did not work.

Any other ideas?

Collapse -

In Bios

by AshishS In reply to CD Rom not showing in My ...

What if you disable the cd rom in BIOS, boot, back into BIOS and enable the cd rom and boot back into OS. Just a thought.

Related Discussions

Related Forums