General discussion

Locked

cdrom not recognized

By dmd32us ·
i am running win98 on one of my older pc's and recently the cdrom will not play. Ive cleaned it but the drive is not recognized. on the boot screen one line after the cdrom info it says "bad command or file name." ive searched for drivers and came up empty. it is a lite-on ltn 382 with generic win driver. any help would be appreciated. thanx md

This conversation is currently closed to new comments.

14 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Comments

Collapse -

cdrom not recognized

by TheChas In reply to cdrom not recognized

If you see that during boot, a DOS mode driver was installed, and is being called up by either autoexec.bat, or config.sys

You can run sysedit, and delete the lines for the CD driver if you do not need DOS mode access.

Verify in BIOS setup that the IDE channel that the CD drive is connected to is set to CDROM or auto.

To check the drive itself, boot from a floppy, and see if you can play a music CD in the drive through the front headphone jack.
If the CD won't play, the drive is likely bad.

If the drive works, verify the IDE cable is connected properly.
Try deleteing all 3 IDE controllers listed in device manager.
When Windows re-boots, it should re-install the correct driver, and bring your CD drive back to life.

If not,you need to download and install the IDE bus-master driver for your motherboard.
If this is a name brand system, start at the mfg website.
If you know whoose motherboard you have, go to their web-site, and download the drivers form there.

If you need help identifying your motherboard, go to either www.motherboards.org
or www.wimsbios.com
both sites have tools and links to help you get the correct drivers.

If you do need DOS mode access, you should be able to download the driver from Lite-On.
Check www.driverguide.com for links.

Chas

Collapse -

cdrom not recognized

by dmd32us In reply to cdrom not recognized

The question was auto-closed by TechRepublic

Collapse -

cdrom not recognized

by lamvidao In reply to cdrom not recognized

Another thing you can try is to look for "Conflict Memory" under Device Manager (windows 2000), I forgot what it was called for win98.
Control Panel-System-Device Manager. Remove the CD and the next time you boot up, Windows should detect a new hardware and installs driver for it or you can install driver manually.

Collapse -

cdrom not recognized

by dmd32us In reply to cdrom not recognized

The question was auto-closed by TechRepublic

Collapse -

cdrom not recognized

by MrRetentive In reply to cdrom not recognized

Check to see if you are operating in DOS Compatibility Mode.

To do this, right click on the My Computer icon on your desktop, click on properties, and then select the Performance tab on the window that appears. The line below the performance status for PC Cards will let you know if any devices are operating in compatibility mode.

If you find you are operating in compatibility mode, click on START > Run and type regedit in the Open line. Then click OK.

When the registry editor appears, click on Edit, then Find and type NOIDE click the Find Next button. If you find that value, delete it, close the registry editor and reboot your computer.

I've seen this resolve your problem many times.

Good luck!

Collapse -

cdrom not recognized

by dmd32us In reply to cdrom not recognized

The question was auto-closed by TechRepublic

Collapse -

cdrom not recognized

by fenaikh In reply to cdrom not recognized

Hi


Reboot the PC then press the Ctrl key choose step by step answer yes to all.when you get the message "bad command or file name." see above the message this is the command causing the message to appear. The message means that the command is missing or no path set for it or misspilled command or damaged file.Edit autoexec.bat (The command ususally is mscdex.exe) search for it this is dos command and put a rem in front of the command. Windows will replace it with a windows driver when you reboot or better install its windows driver your selef, check the manufacurer site for it ) I guessed it since the CD did not work it could be any command though search for it and put the correct path or if it is missing copy it if it is damage replace it.For the CD-ROM drive I would check device manager.In the desktop right click My computer -> properties- TAB to Deivce manager clcik the CD-ROM and check for any yellow "?" then select it then click properties and see if any error code or explanation. Then TAB to driver and see if there any driver problem, check the manufacurer site for updated driver the install the driver . Delete it from the device manager then use the add/remove hardware to add it and install software. .Close then TAB to performance and see if any message saying that there is DOS compatiplity mod . If you have the compatibility mode then either you have a virus or the NOIDE=1 is in the registry, Start-> Run-> (type) regedit
Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VxD\IOS
You should see a value named "NoIDE". Delete it, close regedit and reboot.



good luck


Mohamed

Collapse -

cdrom not recognized

by fenaikh In reply to cdrom not recognized

check to see if you are using DOS mode CDROM driver there are these lines in these files and both located in the root directory of the boot drive: config.sys and autoexec.bat.

use start->run->notepad.exe to edit them and then put a rem infornt of them:

CONFIG.SYS it may include a line similar to:
device=C(dir)\OAKCDROM.SYS /D:MSCD001

AUTOEXEC.BAT it may include a line similar to:
MSCDEX [/L:letter] /D:MSCD001

Collapse -

cdrom not recognized

by dmd32us In reply to cdrom not recognized

The question was auto-closed by TechRepublic

Collapse -

cdrom not recognized

by dene.outterside In reply to cdrom not recognized

I sometimes get no cdrom in windows after a rebuid, so i run Setup again. i.e. insert a 98 boot disk and give it the 3 fingers (ctrl alt del)
install 98 from scratch and you dont have to reinstall apps as 98 picks up all the installed programs fromthe reg. Ensure you select save old system settings as you have something to fall back on. Cause: usually if you have added new hardware as the irq's dma settings are out and a conflict results, just keep tweak these till all kicks in. Check this link out which in fact is from Tech Republic
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/prodtechnol/win98/maintain/devmgr.asp

Back to Windows Forum
14 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums