General discussion

Locked

CHANGING DRIVE LETTERS

By Yogi7 ·
we have a NT4 Terminal Server (SP-3)(obtw, I am one of those office manager/administrators). Well I added a new HD to the server it was a 30 gig drive. NT saw it as 8.5 but did say actual size was 30 gig -- I formatted/partitioned into 3, 7.xx logical drives, (it did this on a test system first-- because I had fears about the Maxtor EZ Drive overlay disk not working on the server. When I attempted this on the server -- it did not like the maxtor EZ drive overlay disk. But since the drive had already been formatted on a NT4 test system I was able to see the drive and go into disk administrator to assign drive letters. I completed that task -- shut the server down to install ram. When I was finished I rebooted and the partitions assigned themselves various letters which threw the server outta wack -- (loss paths etc, couldn't connect to data base) I went into disk admin and reset the letters to the drive -- (one of the new partitions was trying to assign itself and the "D" drive an because of that couldn't connect to our data base.) after resetting and logging off and back on again everything works fine -- but if I have to reboot the server or if it's reboots after a power failure the drive letters go outta wack -- assigning themselves conflicting letters. again the fix is Disk Admin procedure, would appreciate any suggestions, comments or recommendations on how to make the assigned letters stay after a reboot? Please be gentle with me :) I am not a wizard -- just a hard working Office Manager == thanks

From: Yogi7 Date: 1/8/03

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

CHANGING DRIVE LETTERS

by sgt_shultz In reply to CHANGING DRIVE LETTERS

i think you may be stuck on account of how nt hands out drive letters. i wonder if setting up RAID would get you what you need...more hard disk space on c:...maybe others will jump in here...

Collapse -

CHANGING DRIVE LETTERS

by Yogi7 In reply to CHANGING DRIVE LETTERS

The question was auto-closed by TechRepublic

Collapse -

CHANGING DRIVE LETTERS

by TheChas In reply to CHANGING DRIVE LETTERS

First, by default, Windows assigns drive letters in the following order:

C: First HDD primary partition.
Second HDD Primary partition
E: First HDD first logical drive
F:-? Remaining logical drives on First drive.
G:-? Logical drives on second HDD
H: -? Removeable drives.

Here is a link to a utility that can override the 'default' drive assignments.

http://www.v72735.f2s.com/LetAssig/index.html

I have not used it myself, but have had good reports from others who haved used it.

A simple work-around, is to partition any new drives as extended DOS partitions, and create logical drives as needed.
That way, the drive letters will all be assigned after the last logical drive on the existing drive.

Windows will still move your CD and other removable media drives to higher letters.

Chas

Collapse -

CHANGING DRIVE LETTERS

by Yogi7 In reply to CHANGING DRIVE LETTERS

The question was auto-closed by TechRepublic

Collapse -

CHANGING DRIVE LETTERS

by curlergirl In reply to CHANGING DRIVE LETTERS

Is your NT server set up to use a FAT file system instead of NTFS? If you are using NTFS, the drive letters you assign manually should be retained, regardless of reboots. However, I think if you are using FAT, even if it's just the system drive (usually C:) that is using FAT, you will get the behavior you are describing. If this is the case, I would recommend converting all of your partitions to NTFS, and then reset the drive letters as you want. They should then stay assigned as you want them to. Hope this helps!

Collapse -

CHANGING DRIVE LETTERS

by curlergirl In reply to CHANGING DRIVE LETTERS

P.S. - To convert from FAT to NTFS file system, FIRST make sure your system is idle, all users logged off (because it will require a reboot of the server), then go to a command prompt, and type the following command:

convert [drive:] /fs:ntfs

You can add a /v switch on the end if you want the command to run in verbose mode.

Collapse -

CHANGING DRIVE LETTERS

by Yogi7 In reply to CHANGING DRIVE LETTERS

The question was auto-closed by TechRepublic

Collapse -

CHANGING DRIVE LETTERS

by Yogi7 In reply to CHANGING DRIVE LETTERS

This question was auto closed due to inactivity

Back to Windows Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums