Question

Locked

Cisco 2811 telnet lockout after config change

By scampbell ·
I am pretty new to the Router world and am in the middle of "dialing" up some of my remote sites from partial T's to full T's. A consultant was sent to assist in the Cisco configuration and he ended up knowing only slightly more than I do, after my google searches of Cisco CLI. We did finally successfully get 1 site up and running. We used a telnet session to remotely change the config. I have posted the commands he used below.

The Question: after the [no shut] command, the router disconnected and would not let us telnet back in. The only way to get back in to save the config change was to dial in by modem. That worked fine. Is there a reason it locked us out and can I avoid that, so that I can finish the whole job by telnet? I don't have easy modem access into all of my remote site routers.

config t
interface Serial
bandwidth 1544
service-module t1 timeslots 1-24
no shut

Sorry for the novel, but this is a confusing scenario to me. Thanks for the help!

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

How were you

by NetMan1958 In reply to Cisco 2811 telnet lockout ...

able to telnet to it before you configured that WAN interface? Were you on the same LAN as the router and telnetting to the LAN ip?

Just the config snippet you posted shouldn't have affected telnet capability unless, you had a working config on that interface before and changed it. Can you ping the ip assigned to that interface?

Collapse -

Clarification

by scampbell In reply to How were you

Ok, to try and clarify . . . I already have an established WAN between all my sites. Most of the sites are partial T's. The goal is to dial them all up to full T's. I am on the LAN at the server site, telnetting to the remote routers thru an MPLS. So, if I understand you about a "working config," then yes, the router / WAN was already operational. We were just making the change to a Full T. When it disconnected us, I tried to telnet Open aaa.bbb.ccc.ddd just as I did to originally log in, but it would not respond. I didn't try the ping command as I assume that was in essence the same thing (bear in mind that this is all still somewhat new to me).

Collapse -

Still confused

by NetMan1958 In reply to Clarification

If you were configuring the router via a telnet session to the ip address assigned to the interface you were configuring, then the interface could not have been shutdown. So there would have been no need to to enter the no shut command. Can you see why this doesn't make sense?

What I'm trying to figure out is if you have a "back door" into this router, for instance a modem connection. Normally, you do not configure a change to an interface's parameters via telnet if that interface is your only access to the router/switch.

In any event, unless you have a "back door" connection to the router, you are going to have to go onsite to fix this. I would start by putting that interface back to it's original parameters. If it comes back up then chances are that the new config you entered does not match the parameters your telco has setup for that circuit.

Post back if I can be of further help.

Collapse -

I think I've got it . . .

by scampbell In reply to Still confused

Your remark about the no shutdown makes sense and after some further research, I understand why.

I will be able to set up a back door via modem into my routers (just not easily). I am assuming that from your post, using telnet to change the parameters is either just not done, or not an efficient method. I had hoped to use telnet to make all my changes, but it looks like I will have to get my modems in place to do this.

Thanks for all your patience. You've been very helpful.

Back to Networks Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums