Question

  • Creator
    Topic
  • #2272032

    Cisco 506e PPTP Problem

    Locked

    by leo.negron ·

    Hello everyone. I successfully configured a Cisco 506e to allow me access to the internet as well as VPN clients to logon and use the tunnel to touch local clients.

    The problem, however, is that the client that opens the tunnel CANNOT surf the internet or do anything in his own network.

    Does anyone know if I have to change something on NAT, or add a new rule or what? My test client has a static route to send everything to the remote VPN tunnel, but when I take it out I loose the tunnel anyways.

    Any ideas? Here’s my Cisco 506e config:

    Building configuration…
    : Saved
    :
    PIX Version 6.3(1)
    interface ethernet0 auto
    interface ethernet1 auto
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    enable password 8Ry2YjIyt7RRXU24 encrypted
    passwd 2KFQnbNIdI.2KYOU encrypted
    hostname verkspix
    domain-name theverksgrouptest.com
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol ils 389
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    fixup protocol smtp 25
    fixup protocol sqlnet 1521
    names
    name 10.10.11.0 VPN
    object-group network VPN
    network-object VPN 255.255.255.0
    access-list 100 permit icmp any any echo-reply
    access-list 100 permit icmp any any time-exceeded
    access-list 100 permit icmp any any unreachable
    access-list inside_outbound_nat0_acl permit ip any VPN 255.255.255.0
    access-list inside_outbound_nat0_acl permit ip any 10.10.10.0 255.255.255.0
    pager lines 24
    mtu outside 1500
    mtu inside 1500
    ip address outside x.x.x.x 255.255.255.128
    ip address inside 10.10.10.1 255.255.255.0
    ip verify reverse-path interface outside
    ip audit name Verks attack action alarm drop reset
    ip audit name VerksInfo info action alarm
    ip audit interface outside VerksInfo
    ip audit interface outside Verks
    ip audit interface inside VerksInfo
    ip audit interface inside Verks
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpn 10.10.11.100-10.10.11.200
    pdm location 10.10.10.1 255.255.255.255 inside
    pdm location 10.10.10.0 255.255.255.255 inside
    pdm location 10.10.10.0 255.255.255.0 outside
    pdm location VPN 255.255.255.0 outside
    pdm location VPN 255.255.255.0 inside
    pdm group VPN inside
    pdm history enable
    arp timeout 14400
    global (outside) 1 x.x.x.x
    nat (inside) 0 access-list inside_outbound_nat0_acl
    nat (inside) 1 0.0.0.0 0.0.0.0 0 0
    access-group 100 in interface outside
    route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
    route inside VPN 255.255.255.0 10.10.10.1 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    http server enable
    http 10.10.10.0 255.255.255.255 inside
    http 10.10.10.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    tftp-server inside 10.10.10.4 /
    floodguard enable
    sysopt connection permit-pptp
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    telnet timeout 5
    ssh timeout 5
    management-access inside
    console timeout 0
    vpdn group PPTP-VPDN-GROUP accept dialin pptp
    vpdn group PPTP-VPDN-GROUP ppp authentication pap
    vpdn group PPTP-VPDN-GROUP ppp authentication chap
    vpdn group PPTP-VPDN-GROUP ppp authentication mschap
    vpdn group PPTP-VPDN-GROUP ppp encryption mppe 128 required
    vpdn group PPTP-VPDN-GROUP client configuration address local vpn
    vpdn group PPTP-VPDN-GROUP client configuration dns 64.89.70.2 64.89.74.2
    vpdn group PPTP-VPDN-GROUP pptp echo 60
    vpdn group PPTP-VPDN-GROUP client authentication local
    vpdn username lenegron password *********
    vpdn enable outside
    dhcpd address 10.10.10.2-10.10.10.253 inside
    dhcpd dns 64.89.74.2 64.89.70.2
    dhcpd lease 3600
    dhcpd ping_timeout 750
    dhcpd domain verks.pix.com
    dhcpd auto_config outside
    dhcpd enable inside
    terminal width 80

All Answers

  • Author
    Replies
    • #2599801

      Clarifications

      by leo.negron ·

      In reply to Cisco 506e PPTP Problem

      Clarifications

    • #2602471

      Missing Outside NAT

      by dratell ·

      In reply to Cisco 506e PPTP Problem

      nat (outside) 1 10.10.11.0 255.255.255.0

    • #2602390

      ping gateway?

      by sgt_shultz ·

      In reply to Cisco 506e PPTP Problem

      can client ping the gateway. and what gateway: local or remote.

      • #2599177

        Ping

        by dratell ·

        In reply to ping gateway?

        You should be able to ping your local gateway, NOT the remote, because that would be crossing interfaces.

        • #2599154

          Still no-go

          by leo.negron ·

          In reply to Ping

          That did not fix it. I can ping 10.10.10.x and 10.10.11.x

          I cannot ping 10.10.10.1 which is the PIX on the “real” corporate network inside.

          any other ideas?

        • #2599057

          Remove line

          by dratell ·

          In reply to Still no-go

          route inside VPN 255.255.255.0 10.10.10.1 1

          I don’t think you need this line as your already being routed because of VPN service.

        • #2599545

          Fixed

          by leo.negron ·

          In reply to Remove line

          Hey guys I found my problem. It ws not in the PIX AT ALL. It was in my TCP/IP settings on my test client. I had the box checked that says route all through VPN. I unchecked it and *poof* it works now.

          Just thought I’d let everyone know in case anyone else has this problem. I feel stupid.

        • #2626950

          Where is that setting at?

          by tom.edukonis ·

          In reply to Fixed

          I have looked in my connection properties and do not see it. Thanks

Viewing 2 reply threads