Question

Locked

cisco config for internet access - something missing?

By markrr4 ·
Hi all - I'm new to posting on the forum but have been looking for a while :)

I'm trying to set up a cisco 1841 at home for internet access via the ethernet port on a sky router. I've got the wan port set to dhcp, static ip on the lan port and a dhcp pool in the same network as the lan port for my pc to pick an address up from. All interfaces are up and all looks good but I can't access the internet?? I can ping the sky gateway from my pc though. Am I missing something on the config?

Thanks :) any ideas appreciated.

Sky gateway 192.168.0.1 255.255.255.0



Router>en

Router#sh run

Building configuration...



Current configuration : 1063 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool fireblade

network 200.10.10.0 255.255.255.0

default-router 200.10.10.1

lease 1 1 1

!

!

!

!

!

!

!

interface FastEthernet0/0

description LAN INTERFACE

ip address 200.10.10.1 255.255.255.0

ip nat inside

speed 100

full-duplex

!

interface FastEthernet0/1

description WAN INTERFACE

ip address dhcp

ip nat outside

no ip route-cache cef

no ip route-cache

speed 100

full-duplex

no cdp enable

!

interface Serial0/0/0

no ip address

shutdown

no fair-queue

clock rate 2000000

!

ip route 0.0.0.0 0.0.0.0 192.168.0.1

!

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet0/1 overload

!

access-list 1 permit 200.10.10.0 0.0.0.255

access-list 1 permit any

!

!

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

login

!

scheduler allocate 20000 1000

end



Router#ping 192.168.0.1



Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

Router#

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Is the Sky router also a NAT router?

by robo_dev In reply to cisco config for internet ...

I assume that you know that doing double-nat is bad.

My first guess is that I don't see any dns forwarder entries.

If you do a NSLOOKUP on a client PC, it would fail unless DNS queries are making it to your ISP's DNS server and back.

Can you get to an external site via IP address?

Can you ping the DNS server of your ISP?

Collapse -

NAT

by CG IT In reply to cisco config for internet ...

ip nat pool NATPOOL 200.10.10.XXX 200.10.10.XXX netmask 255.255.255.0

[where NATPOOL is the name & XXX is the ip range]

ip nat inside source list 1 pool NATPOOL

[where source list is the NATPOOL of addresses]

access-list 1 permit 200.10.10.0 0.0.0.255
[the entire pool of addresses and the subnet mask is 0.0.0.255]

also try simple NAT without overload so you have NAT virtual reassembly, don't see that in your config.

Collapse -

Config is fine

by satty180 In reply to cisco config for internet ...

All the configs are looks fine. can you check the DNS ip part. No config found related to the DNS, try to ping the DNS IP before moving forward to change any of the configuration.

Collapse -

config

by markrr4 In reply to Config is fine

thanks - i'll try this tonight !!

Collapse -

good call satty!!!

by markrr4 In reply to config

yes - it was dns - added sky's dns server into the dhcp server config and hey presto!!

Thanks to all for taking the time to read and reply - much appreciated!!

Back to Networks Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums