General discussion

Locked

Cisco recovering password

By v.prakash ·
I have a cisco 3662 router. I suppose some one has hacked it last week, and they have disabled the password recovery functionality.(Usually we can go to ROMMON mode and break the password. However router is not going to ROMMON mode, even if we press CONTROL-BREAK at the appropriate place("image text-base.....")

The other option i got in cisco site is that i should remove the NVRAM and put it again, as it will erase the configuration. My router's NVRAM does not appear to be removable as it looks to be soldered to board.

SO any other idea other than above is most welcome, and would be helpful to us.(The Hacker has gracefully untouched the configuration of our router and all the connections to the router are working fine.)

One useful info is our router has an SNMP Read only string configured.

Suggestions welcome to sort the problem

This conversation is currently closed to new comments.

8 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by aquias2000 In reply to Cisco recovering password

Well, I did some digging and this is what I came up with http://www.cisco.com/en/US/products/hw/routers/ps133/products_tech_note09186a0080174a34.shtml

That page has a listing of other possible methods (including one reboot method) to force yourself into ROMMON mode.

Give it a shot and see what happens.

Collapse -

by v.prakash In reply to

Poster rated this answer.

Collapse -

by v.prakash In reply to Cisco recovering password

Thanks, it was a new one, but i tried it out and it did not work

Collapse -

by aquias2000 In reply to Cisco recovering password

Well,

I did some more digging, it seems like there are limited options at this point. I know there are hacks to run against the router to break the password but I don't have any handy.

Some of what I found that has been suggested includes changing the amount of DRAM or SDRAM in the system as it may force you to reload the IOS.

If that doesn't work you may need to see if Cisco can provide further assistance. This page

http://www.cisco.com/en/US/products/hw/routers/ps274/products_installation_and_configuration_guide09186a008007ce07.html#wp72194

provides a lot of physical specs to the system and gives a pretty detailed explination of adding and removing items and of their affect on the router.

Collapse -

by CG IT In reply to Cisco recovering password

humm question here, the first answer gave you how to do a standard control + break key using the hyperterminal com 1 connection and setting the hyperterminal connection values to 1200 baud, 8 bit, no flow control. what you do is make a connection using those values and reboot the device while still connected then , depending upon which Cisco device you got, you press the space bar immediately after you turn on the device. that emulated the control+break when the keyboard control+ break doesn't work. That would force a Rommon prompt. If you tried that and it doesn't work, you may need to contact Cisco TAC to get the default Cisco admin password for your device.

Read only SNMP won't help ya a bit as its "Read" only. If you knew the public Read/Write string password, could do it that way OR try getting in through Configmaker or CiscoWorks discovery tools.

Collapse -

by aboadel81 In reply to Cisco recovering password

I had the same problem Yesterday,
do the follwing steps to can enter to the ROMMON:
1-Connect to the router from hyperterminal by the follwing settings:
1200 baud rate

No parity

8 data bits

1 stop bit

No flow control
after connect you don't see any output on the screen.
2-Turn the router off and then turn on,in the same time of turning on press on the spacebar for 10-20 seconds,you will see this generates a signal similar to the break sequence.
3-during this signal disconnect the terminal and reconnect with the default 9600 baud rate,
after connected press on Ctrl+Break and wait,
you will enter to the ROMMON.

Collapse -

by v.prakash In reply to

Sorry, IT didnt work for us. In fact we had tried it earlier. our IOS version is 12.0(7)xK2. But CISCO is saying that the "no recovery for password" feature is possible only from 12.3. SO is this an bug for the lower IOS which our router is ?

Collapse -

had the same problem

by slava.minin In reply to Cisco recovering password

for me Ctrl-Break sequence worked when I waited till main memory is configured to 32 bit mode. You will see the following output in the terminal window: "Main memory is configured to 32 bit mode...." then type break sequence which will bring you to rommon.

Back to Networks Forum
8 total posts (Page 1 of 1)  

Related Discussions

Related Forums