Question

Locked

Cisco Router Route of Last Resort

By waterboy550 ·
I am testing out a Cisco 1841 Router and need to set a route of last resort. I made a static route of "ip route 0.0.0.0 0.0.0.0 172.16.48.1". Then issued the command "ip default-network 172.16.48.1". This now allows me to ping anything on the 172.16.0.0/16 network from the router. But I am not able to ping anything on the internet or outside of this network from the router. Here is my running config and routing table. What am I missing? fa0/0 is facing the network 172.16.0.0/16, and fa0/1 is facing another internal network.

Router#show run
Building configuration...

Current configuration : 925 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
no ip domain lookup
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
interface FastEthernet0/0
description outside LAN
ip address 172.16.50.1 255.255.240.0
duplex auto
speed auto
!
interface FastEthernet0/1
description internal LAN
ip address 10.2.3.1 255.255.254.0
duplex auto
speed auto
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
!
interface Vlan1
no ip address
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.48.1
ip route 172.16.0.0 255.255.0.0 172.16.48.1
!
no ip http server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end

Router#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.48.1 to network 0.0.0.0

172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.48.0/20 is directly connected, FastEthernet0/0
S 172.16.0.0/16 [1/0] via 172.16.48.1
S* 0.0.0.0/0 [1/0] via 172.16.48.1
Router#

This conversation is currently closed to new comments.

10 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

destination: subnet mask: next hop router

by CG IT In reply to Cisco Router Route of Las ...

that's it.

so how is the traffic on the directly connected interface going to get to the next hop router? and how is that next hop router going to find the 172.16.40.0/20 subnet

and what's this interface?

interface FastEthernet0/1
description internal LAN
ip address 10.2.3.1 255.255.254.0
duplex auto
speed auto

Collapse -

Cisco Router Route of Last Resort

by waterboy550 In reply to destination: subnet mask: ...

The static route is pointed to the next hop. All traffic needs to be routed through 172.16.48.1/27. I setup the static route of 0.0.0.0 0.0.0.0 to 172.16.48.1. This network is accessible via fa0/0. Fa0/1 is going to be a new network. This isn't the most concern now, I just need to figure out how to get the router to be able to route traffic destined for the outside world to route to 172.16.48.1.

Collapse -

right from your route table

by CG IT In reply to Cisco Router Route of Las ...

to direct all traffic coming into a router out an interface use the wildcard 0.0.0.0 0.0.0.0 [interface #]

so if traffic comes in on Fa 0/0 and you want it to go out Fa 0/1 the gateway of last resort would be 0.0.0.0 0.0.0.0 Fa 0/1

All traffic not destined for the local network would be sent out Fa 0/1.

this should show up in your route table after config t CTL + T

Note: make sure the WAN port on that 1800 series is the interface all traffic not destined for the local network is sent out from.

Note: this is for a router in router mode not gateway mode.

If it's gateway you need to do NAT.

Collapse -

routing

by waterboy550 In reply to right from your route tab ...

Sorry for all the confusion. Lets forget about interface fa/01. I have my router connected to a network of 172.16.0.0/20. In my routing table it shows this.
C 172.16.48.0 is directly connected, FastEthernet0/0. So this is the network directly connected to fa0/0. Currently when running ping commands on my router I can ping 172.16.48.1. This is what I want all traffic to be forwarded to. However my router can't ping anything on any other network. It seems that it is dropping this packets or not routing them to 172.16.48.1 to handle them. I have setup the static route of 0.0.0.0 0.0.0.0 172.16.48.1. I was told this would route all traffic not matching anything in the routing table. It seems to only be working for the 172.16.X.X network however. Sorry if I'm not understanding your explanation I'm a true beginner.

Collapse -

IP route

by CG IT In reply to routing

diagram

172.16.0.0/20 connects to ?

172.16.40.0/? local LAN connects to ? switch? host? another router ? If this subnet [router interface local lan] is your local lan, than any host behind this router should be able to ping the interface.

for traffic to leave that router and go elsewhere, you have to tell it where to go and it needs an interface to send the traffic out of to get there.

So if you have 2 Fa interfaces, one is local lan and one is WAN. traffic not destined for the local LAN goes out the WAN interface.
router # config t
Router(config) # ip route 0.0.0.0 0.0.0.0 {interface to send traffic out]
Router(config) # ip routing
router(config) #router eigrp (designation)
Router(config-router)# network X.X.X.X.
blah blah etc
ctl+z
router#
router# sh ip route eigrp
and you have your eigrp route table showing provided that other routers are using eigrp.

can do rip v2 if you want.

Collapse -

Verify subnet mask for 172.16.48.1

by NetMan1958 In reply to routing

You say you can ping 172.16.48.1 from your router, can you verify the subnet mask on the other router's interface that is using 172.16.48.1?

Collapse -

I got the impression that 172.16.48.1 was the 18 41 Fa 0/1

by CG IT In reply to Verify subnet mask for 17 ...

interface for the LAN.

the other interface Fa 0/0 is his WAN interface. That's this config

interface FastEthernet0/0
description outside LAN
ip address 172.16.50.1 255.255.240.0
duplex auto


That in turn connects to his ISP. For hosts behind the 1800 to get to the internet, he's gotta run NAT inside and outside.

The gateway for all clients behind the 1800 is the 1800 local address. sorta the expensive router for broadband setup...

those 1800s also have a built in switch [8 port] so its possible that the LAN interface isn't configure properly for hosts that directly connect to the 1800 with NAT. SDM would provide him with an easy way to configure it.

Since I didn't look I'm not sure if he's assigned the router itself an address in which all hosts that connect to it's 8 port switch all must be on the same subnet. Not sure how he's doing that.

Collapse -

Different subnets

by NetMan1958 In reply to Cisco Router Route of Las ...

"interface FastEthernet0/0
description outside LAN
ip address 172.16.50.1 255.255.240.0"
172.16.48.0 255.255.255.240 includes 172.16.48.0 - 172.16.63.255, so your router knows that 172.16.48.1 is directly connected to FastEthernet0/0

"The static route is pointed to the next hop. All traffic needs to be routed through 172.16.48.1/27."
172.16.48.0 255.255.255.224 includes 172.16.48.0 - 172.16.48.31, so the other router knows that 172.16.50.1 is not directly connected and will send traffic to this subnet to it's default gateway.

Collapse -

Netman's the pro on this give him 10 thumbs up

by CG IT In reply to Different subnets
Back to Networks Forum
10 total posts (Page 1 of 1)  

Related Discussions

Related Forums