Cisco VPN Client issue

By rey6221 ·
Hi Everyone,

I am having an issue with a Lenovo T520 (4242) with a built in 3g modem (Telstra network) and the cisco VPN client (v5 32bit running on Windows 7 32bit). The VPN for my organisation will work when I connect via my phone acting as a hotspot, and when i connect that way i have full functionality. When I try and use the internal 3g modem, the connection connects, authenticates, and then I have nothing at all, no internet access, and I am not able to ping any remote hosts.
So far I have reduced the MTU, turned off the firewall, made sure that the connection is set to a work connection and not a public one, I have made sure the connection is going through the telstra.extranet APN so that it gets an ip address that isnt in the 10.x.x.x range and thats about it.

I am out of ideas, and was hoping someone could give me an idea as to why I am not getting any connectivity when on the internal 3g connection.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -


by Rob Kuhn In reply to Cisco VPN Client issue

Who is your 3G carrier?

I ran into a similar problem using a Sprint 3G MiFi device. Sprint wasn't able to help or provide any sort of assitance.

When I tried a Verion 4G MiFi it worked fine.

FWIW, our Cisco VPN Client is v5.0.07.0290.

Enable Logging in the client and see if there are any error messages reported.

Collapse -

Cisco Readme

by robo_dev In reply to Cisco VPN Client issue

" VPN Client 5.0.07 features the following:

Support for Windows 7 on x64 (64-bit). This release, however, does not support WWAN devices (also called wireless data cards) on Windows 7 x86 (32-bit) and x64. For support of WWAN devices on Windows 7, please use the Cisco AnyConnect Secure Mobility client."

Collapse -


by rey6221 In reply to Cisco VPN Client issue

Thanks for your advice guys, I'm not sure how I missed that in the readme, but after looking through the logs and investigating the issue further, it appears that the cisco vpn client has issues with the drivers for 3g cards. There are a few work arounds for this that I found, but the best solution I have found is that instead of using the cisco VPN client to connect, I downloaded the open source alternative shrewsoft vpn client, then imported the settings from the cisco vpn client. Through my testing this morning it has seemed to fix all the issues!

And Rob my carrier was Telstra - The main Telco in Australia

Thanks again for your help guys

Related Discussions

Related Forums