Question

Locked

Citrix ICA connections. How to set default login page to your domain

By jhussey ·
I have a problem with Citrix ICA connections whereby when I attempt to make a connection to the published desktop the default login environment is set to the "Workstation (This computer)" rather than our companies Domain. In order to fix it I have to use the drop down box and select the ABC-CORP domain and then I can put in my credentials.

This possesses a real problem for our users because they cannot remember to use the drop down box and select the domain option before logging in.

How can I fix this so it always defaults to domain option instead of workstation.

Any help is greatly appreciated

This conversation is currently closed to new comments.

4 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

try this

by lowlands In reply to Citrix ICA connections. ...

This setting is determined by a registry setting.

Make sure that under HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\

The following three keys are set to your domainname instead of to the computername.

DefaultDomainName=ABC-CORP
AltDefaultDomainName=ABC-CORP
CachePrimaryDomain=ABC-CORP

To make sure it stays that way, you can either create a logoff script on the server that sets these values, even when someone logs on to using the local server, or you can remove write permissions to the registry values.

Collapse -

Anything in Group Policy that might do this?

by jhussey In reply to try this

Lowlands,

The login script might be on option, but I was wondering if there is somethign you know I can set in Group Policy that might do this for me. We are trying to avoid modifying our current login scripts as much as possible.

Thanks for any help you can give me.

Collapse -

Console

by steven.bamford In reply to Anything in Group Policy ...

Just as a note, this usually happens if you logon to one of the servers local accounts using the console. If you logon back on to it through the domain, that normal sets it back fine.

Bit of a pain though.

Back to Desktop Forum
4 total posts (Page 1 of 1)  

Related Discussions

Related Forums