General discussion

Locked

Clients lose their login after idle time

By Mark ·
I am converting a network from Netware NDS to W2K3 with Active Directory. There seems to be a problem, especially with WIN98 clients where the login is lost after an idle time. I can't seem to find the idle time setting in GPE. At first the clients would be locked out. I disabled the lockouts due to password problems and now they don't get locked but the user has to log off and back on again. This is unacceptable for my client and I can't seem to figure out a solution. I loaded the DS 98 clients and thought it was working, but they started doing it again. Any ideas? If the clients keep files open, they seem to stay on, but I'm not sure cause the time period seems to vary.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Mark In reply to Clients lose their login ...

After working with this issue further, it is apparent that the W2K3 server is dropping all clients after an idle time period. This is apparent in the 2K/XP workstations by an "X" on the drive icons in My Computer. These stations are smart enough to login again when the connections are requested again. The 9X workstations just reply with an "Access Denied" message. The 9X stations have to goto Start, Logoff Username and then logon again to get going. I have set the stations to open a dummy network file on the Server, but if the person closes this Application, then we have the problem again. Certainly others are having this problem and I need a workable solution.

Collapse -

by Mark In reply to Clients lose their login ...

Point value changed by question poster.

Collapse -

by pierrejamme In reply to Clients lose their login ...

Not sure about W98, but W2k and XP Pro thought they should have Power Management on their NICs??? Stupid stupid.
Check the Device Manager and see if the NIC has Power Managemnt turned on? It wil say something like "Allow this device to save power" with a check box.

Collapse -

by pierrejamme In reply to

Sorry for you that you are leaving NDS, Oh well

Collapse -

by Mark In reply to

It's not a power managment issue. It's a Windows 2003 default security setting issue or something similar. The workstations stay connected to the Windows 2000 server. It's the 2K3 server that disconnects them. Win9X is not smart enough to relogin without the user restarting the login process. The 2K/XP stations work fine.

Collapse -

by rajivsh In reply to Clients lose their login ...

I have the same problem with W2k/XP clients on WIN2k Domain controller. I couldn't figure out, this is very frustratring. Pleaset let me know if you have the solution.

Collapse -

by Mark In reply to

That's interesting, cause I don't have problems with NT clients. They log back in when needed. I'm pretty sure I did see an idle timeout setting in Win2K Group Policies, but I couldn't find it in W2K3. Also the 98 clients don't have this problem with the WIN2K Server that is on the same Network. It's hard for me to believe that I haven't gotten any responses on this. Surely others are seeing this problem.

Collapse -

by Mark In reply to Clients lose their login ...

Here's something that might help your 2K/XP clients:

http://www.winguides.com/registry/display.php/891/

Control Keep Alive Parameters (Windows NT/2000/XP)
These settings control how Windows manages connection keep alive transmissions. Including the timeout before keepalives are sent and the interval between keepalive transmissions.

Open your registry and find the key below.
Create new DWORD value named "KeepAliveTime" and set it to equal the number of milliseconds to wait before sending keep alive packets (the default is 2 hours - 7,200,000 milliseconds).

Also create a new DWORD value called "KeepAliveInterval" and set it to equal the time in milliseconds between retransmissions of keepalives, once the KeepAliveTime has expired (the default is 1 second - 1000 milliseconds).

Restart Windows for the change to take effect.

(Default) REG_SZ (value not set)
KeepAliveTime REG_DWORD 0x006DDD00 (7200000)
KeepAliveInterval REG_DWORD 0x000003e8 (1000)

Registry Settings
System Key: [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]
Value Name: KeepAliveTime, KeepAliveInterval
Data Type: REG_DWORD (DWORD Value)

Collapse -

by Mark In reply to Clients lose their login ...

This question was closed by the author

Back to Networks Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums