Question

Locked

combo drive not detected by windows

By dipankar_diwakar ·
hey!

my problem is rather peculier...

earlier this year when updating the firmware on my combo-drive my system just hung and upon restarting it i noticed that my combo drive had gone dead. the eject button did not work, the drive was not detected in the bios and even the little green lcd light was gone! i tried everything but could not recover it, then i came across someone who also had the same drive and then i requested him to give me a backup of the firmware in binary(.bin) format so that i could use an application like MTKFlash to recover my drive.

the good samaratian then told me that he could not use MTKFlash to get the firmware backup, apparently MTKFlash is incompatable with the Asus 5216a combo drive. so we then tried the XSF utility. that worked and now i have the firmware which i used to recover the drive with. the drive is now detected by the system bios and the lcd light works and so does the eject button but that's about it! nothing else works! the drive is not detected by windows and so none of the windows based applications is able to acess it... further if i start the system with a bootale cd in the drive then also the system boots straight to windows... and yes, i have tried changing the ide channels...

on a side note, i have 40 conductor cable, so would upgrading to 80 conductor cable make any diffrence?

peace

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Re: Combo drive not detected

Have you tried and looked in the "device driver" section, the drive might have a little red or yellow tag, right click and go to "update", you might be asked for the driver disk that can with your drive. Or you could reset your bios to the earlier bios. (Before the update) Have a look on the Asus web site and see if you need to update (flash the disk drive) the software rom on the drive. I had to with HP dvd combo drive to work properly.

http://www.asus.com

Collapse -

still not detected

by dipankar_diwakar In reply to Re: Combo drive not detec ...

hey, thanks for repling!

i had tried the device manager and even tried to use the manually install hardware option, but like i said nither windows nor any windows based utilities detect my drive. i tried the latest asus firmware(version 1.13) but even that did not detect the drive. this is what you ment when you said that i'll need to update the flash rom right?

my problem is that i kinda live in a remote area there is no asus service center nearby, and i dont wanna make a long trip specificly to fix my drive. but i guess the best chance i have to fix my drive is to take it to some asus center.

thanks again for replying... i guess i'll have to put my drive in cold storage till i make a trip to the big city!

peace

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums