Question

Locked

Compaq EVO D510 won't boot up

By idlewanderer7 ·
Hello All,

On Friday it froze - completely seized up - I had to force shut down. Tried to turn it back on and it wouldn't. I tried a few things but nothing works. Some things about the computer/that I noticed:

-power supply fan blows air out
-fan inside case works
-green LED light on front case is lit
-LED hard drive light is amber

I took out the RAM and put in another stick, but problem persists. I have two hard drives so I tried them each separately but no dice.

When I turn it on I hear it start to go into boot up mode but the hard drive seems quieter than normal. Sometimes I'll hear a faint beep when I push the power button on, other times not. The monitor nor keyboard receive any info from the computer except for two times when I tried to turn it on, the "Compaq" screen came up on the monitor but hung there and didn't do anything so I had to force shutdown again.

Any info or insight anyone has is greatly appreicated. I know someone who will take a look at it later in the week but if there's something else I should do/try please let me know.

edit: forgot to mention that the power LED light on the case stays on (less bright) when I had forced shutdown.

This conversation is currently closed to new comments.

1 total post (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Power converter

by mjd420nova In reply to Compaq EVO D510 won't boo ...

This sounds like the power converter section, usually a small board mounted above the main supply plugin, has failed. It's job is to take battery power, AC adapter power and convert it to 12 volts to power the hard drives.

Back to Hardware Forum
1 total post (Page 1 of 1)  

Related Discussions

Related Forums