General discussion


Compaq Presario CQ62 No Power

By dinkey ·
Is it my motherboard? I've got a Compaq Presario CQ62-219wm laptop that I'm working on. It has no power. I've tried the hard reset with no battery, no adapter, press & hold power button. That didn't work. I tested the power adapter it's getting power even tried a second adapter still no power. I changed out the power jack but still no power. There is an led on the power jack itself and I noticed when plugging the adapter in it there is no light that comes on. Any other suggestions? Or should I just replace the motherboard? Computer is no longer under warranty.

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

Try Re-posting in Q&A...

It could be a loose connection on the power jack, anyway...
Try re-posting in the Q&A
section.The 'Discussion' forum is for matters of general discussion, not specific problems in search of a solution. The 'Water Cooler' is for non-technical discussions. You can submit a question to 'Q&A' here:;content

There are TR members who specifically seek out problems in need of a solution. Although there is some overlap between the forums, you'll find more of those members in 'Q&A' than in 'Discussions' or 'Water Cooler'.

Be sure to use the voting buttons to provide your feedback. Voting a '+' does not necessarily mean that a given response contained the complete solution to your problem, but that it served to guide you toward it. This is intended to serve as an aid to those who may in the future have a problem similar to yours. If they have a ready source of reference available, perhaps won't need to repeat questions previously asked and answered. If a post did contain the solution to your problem, you can also close the question by marking the helpful post as "The Answer". . .

Related Discussions

Related Forums