General discussion

Locked

Configure Cisco 2509 to provide console access

By eric ·
I am trying to figure out how to configure a Cisco 2509 to provide console access to another router and a Sun Ultra 1. Here is a copy of my current config:

Current configuration:
!
version 10.3
service udp-small-servers
service tcp-small-servers
!
hostname 2509
!
enable secret 5 $1$5ZqH$u6xk4T2Nbn3q/sP/NhSRD1
enable password xxxxxxxxx
!
!
interface Loopback0
ip address 172.21.1.1 255.0.0.0
!
interface Ethernet0
ip address 192.168.1.10 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip host hostname 2001 172.16.1.1
ip host cisco2501 2001 172.21.1.1
!
line con 0
line 1 8
no exec
transport input telnet
flowcontrol hardware
line aux 0
transport input all
line vty 0 4
password xxxxxxxx
login
!
end

Any help would be much appreciated.

Thanks,
Eric

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Here is what we use.

by TheNetworkGuy In reply to Configure Cisco 2509 to p ...

Here is the config from our console router. It is a Cisco 2511.

version 12.2
service nagle
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
!
hostname CONSOLE
!
logging buffered 16384 debugging
logging console critical
aaa new-model
aaa authentication login console local
enable secret anystring
!
username anyone password anyword
clock timezone EST -5
clock summer-time EDT recurring
ip subnet-zero
ip domain-name yourdomain.com
ip name-server 10.145.66.189
ip name-server 10.145.66.250
!
!
!
!
interface Loopback0
no ip address
no ip proxy-arp
!
interface Ethernet0
description Connection to Network
ip address 10.41.39.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
no fair-queue
!
interface Serial1
no ip address
shutdown
!
ip default-gateway 10.41.39.254
ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
no ip http server
!
logging source-interface Loopback0
logging 10.68.2.80
access-list 77 permit 10.91.105.250
access-list 77 permit 10.41.251.1
access-list 77 permit 10.41.53.253
access-list 77 permit 10.91.6.189
access-list 77 permit 10.91.6.171
access-list 77 deny any
access-list 78 deny any
!
snmp-server community ReadOnlyString RO 77
snmp-server community ReadWriteString RW 77
snmp-server community ILMI RW 78
snmp-server contact Network Services
snmp-server enable traps tty
banner motd #

This is a private system. Do not attempt to login
unless you are an authorized user.

Esto es un sistema privado. No trata entrar a
menos que eres un usuario autorizado.

#
!
line con 0
exec-timeout 20 0
password Someotherstring
login authentication console
transport preferred telnet
line 1
location Internet Switch #1 console port
password Someotherstring
flush-at-activation
transport input all
line 2
location Internet Switch #2 console port
password Someotherstring
flush-at-activation
transport input all
line 3
location Internet Switch #3 console port
password Someotherstring
flush-at-activation
transport input all
line 4
password Someotherstring
flush-at-activation
transport input all
line 5
location Internet router 1 Console
password Someotherstring
flush-at-activation
transport input all
line 6
location Connection to Firewall
password Someotherstring
flush-at-activation
transport input all
line 7 16
password Someotherstring
flush-at-activation
transport input all
line aux 0
password Someotherstring
line vty 0 4
exec-timeout 20 0
password Anyotherstring
login authentication console
transport preferred telnet
transport input telnet
!
ntp server 10.41.1.39
end


Hope that helps.

Collapse -

Your config

by tomard In reply to Here is what we use.

Using your config (just trying to follow it), how do you select what switches' con0 you want to login to?

I am assuming you are using either telnet OR
are con 0 to access your 2511?

Collapse -

Cisco 2509 access problem

by mylovecisco In reply to Configure Cisco 2509 to p ...

I faced the same problem.. please check the configuration below..
==================================
line con 0
exec-timeout 0 0
line 1 7
terminal-type download
transport preferred telnet
transport input telnet
flowcontrol hardware
line 8
terminal-type download
transport preferred telnet
transport input telnet
=================================
I use line 8 for my cisco 3550 switch. if you use flowcontrol hardware, you can not access from your access server 2509. I didn't use flowcontrol for connecting switch. Check the config and apply as per your tty line for accessing switch. Hope you understand..

Thanks
mylovecisco

Back to IT Employment Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums