General discussion

Locked

Confused install linux 17gig hard drive

By bobbys ·
I thought the problem was the bios was to old to use the whole drive. I had a 6gig installed and was upgrading to a 17. After many problems (installs fine but will not boot many errors missing files.) I decided to only partition 7gig of the drive. The same thing happened. It boots up checks drive everything is fine the right after it builds the rpm's it cant find dir's or files and bombs. it is mandrake 6.0 and a western digital hard drive. I am really lost because it worked fine with my 6gig. Any help?

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Confused install linux 17gig hard drive

by hugevlad In reply to Confused install linux 17 ...

Hi !

Yes, old BIOSes can`t interoperate with big drives. But linux work with hardware directly, not using BIOS. Only one stage, when BIOS functions used, is kernel loading (using lilo).
I suggest you to split your hard drive onto some partition.To prevent problems with kernel loading, create small partition for kernel image only (you can mount it, for example, to /boot). Be sure, that this partition reside _before_ 1024 cylinder. After kernel loading all other partitions will be easyly accessible.

With best regards,
Vlad.
mailto:hugevlad@yahoo.com

Collapse -

Confused install linux 17gig hard drive

by bobbys In reply to Confused install linux 17 ...

you are correct. What I did was become very angry and went out and bought mandrake 7.0 full. Well I noticed this placed a /boot at the beginning. All worked fine. Just wish I would have read this first but it was only 34 bucks :)

Back to Linux Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums