General discussion

Locked

Connecting two routers with AUX ports

By BizIntelligence ·
<pr> I have been preparing for my CCNA recertification and therefore I have setup a lab. So I borrowed used two Cisco 1721 Routers from my company. Unfortunately, those routers don't have serial interfaces. Also there is only one FastEthernet interface on each router. I wanted to connect these two routers using ports other than FastEthernet. The reason behind that was to use FastEthernet interfaces for local LAN on each side of routers. Some thing like shown below: </pr>
<br>
<pr>
<b align=center>LAN ------ FA0/1-ROUTER1____ROUTER2-FA0/1---LAN </b>
</pr>
<br>
<pr>After searching on CISCO references I found following steps to connect two routers back to back via AUX ports: </pr>
<pr> <b>Configurations</b>
This document uses these configurations:
<b>Router 1</b>
*********************************************
Router 1
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router1
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
!--- The async interface that corresponds to the AUX port.
!--- Use the show line command to determine which async interface corresponds
!--- to the AUX port.
ip address 192.168.10.1 255.255.255.0
!--- The IP address on the AUX ports of both routers are in the same subnet.
encapsulation ppp
!--- Set PPP as the encapsulation.
async default routing
!--- This allows routing protocols on the link.
async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Async1
!--- The default route points to the Async1 (AUX port) interface.
logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
!--- Line configuration for the AUX port.
modem InOut
transport input all
!--- This allows all protocols to use the line.
rxspeed 38400
!--- Set the Rx speed (identical to the TX speed of the other router).
txspeed 38400
!--- Set the Tx speed (identical to the RX speed of the other router).
flowcontrol hardware
line vty 0 4
login
!
end
<br>
<b>Router 2</b>
********************************************
Router 2
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname Router2
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface Async1
!--- The async interface that corresponds to the AUX port.
!--- Use the show line command to determine which async interface corresponds
!--- to the AUX Port.
ip address 192.168.10.2 255.255.255.0
!--- The IP address on the AUX ports of both routers are in the same subnet.
encapsulation ppp
!--- Set PPP as encapsulation.
async default routing
!--- This allows routing protocols on the link.
async mode dedicated
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
!--- This default route points to interface Ethernet0.
logging buffered
!
line con 0
exec-timeout 0 0
line aux 0
!--- Line configuration for the AUX port.
modem InOut
transport input all
!--- This allows all protocols to use the line.
rxspeed 38400
!--- set the Rx speed (identical to the TX speed of the other router).
txspeed 38400
!--- set the Tx speed (identical to the RX speed of the other router).
flowcontrol hardware
</pr>

<pr>I have removed the static routes so that I can use other routing protocols. The above method is working fine so far. I am just wondering if it is suitable method to prepare for CCNA...</pr>
<br>
<pr>Should I need to by serial WICs and then
prepare?</pr>

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Another lab setup option

by goodoldguy In reply to Connecting two routers wi ...

You can also use a console connection to do the initial configuration for both routers to get started. Then use the console connection on one, and telnet to the other through the ethernet interfaces. That will lead to using access lists, ip routes and, perhaps most important, learning what actions can disconnect you from a remote router that you're configuring, to which you have access only through ethernet.

Collapse -

Another option

by NetMan1958 In reply to Connecting two routers wi ...

Although I have a nice lab at home now, when I was preparing for the CCNA I rented lab time here:
http://www.mindtechcom.com/
Good rack for CCNA and very reasonable rental prices.

Back to IT Employment Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums