Question

Locked

Connection-specific DNS Suffix won't change appropriately

By mdphoenix ·
I have a domain with 25 users. Some have laptops, some do not. When the lawyers take their laptops home and use their wireless network, all is well. When they return to the office, they cannot access network resources. They receive a DHCP address, but cannot connect to their shared drive, cannot synchronize and cannot surf the web. If an "ipconfig /release" and "ipconfig /renew" is performed, all is well again. Looking deeper into the problem, the "Connection-specific DNS Suffix" is not correct. It still shows their home domain name from their router. Laptops should be able to roam. How do I get this to work properly?

There are SOME laptops in the office that will work appropriately from home to office, etc.

I need to fix this quick or the boss is bringing in external help and that'll just make me look bad. Any ideas?

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

So...did you get anywhere?

by mgriba In reply to Connection-specific DNS S ...

I have a domain that I inherited that was wide open when I got it. The company has grown and with it securities need tightening. Laptop users are now coming on board. I have a user in another state who received her laptop that worked fine at the office, and at my home (to test). It would not connect to any wireless/wired network she tried. I am receiving the laptop back via shipment and expect the problem to be with a Group Policy and DNS settings. The domain specific DNS of the default workstation policy seems to still be in place. Would that be the culprit? Thanks.

Collapse -

Not sure

by mdphoenix In reply to So...did you get anywhere ...

If the Domain Specific DNS suffix is different from that of the Domain to which she's trying to authenticate, then I'd think she won't be able to authenticate.

You state that she cannot connect to any wireless or wired network. Does that mean she actually cannot connect? Like the laptop doesn't detect a connection? Or that she can connect but cannot obtain an IP?


On a side note - no, my problem is not fixed. I still deal with it on an almost daily basis. For my users with Admin rights, I've created a batch file and put it on their desktop which runs Ipconfig release, flushdns, renew, registerdns in that order and all is well. For those who do not have Admin rights, I have to manually perform this task remotely for them.

Collapse -

Maybe this will help???

by nnadministrator@newcastle In reply to Not sure

Do you have DHCP option 015 DNS Domain Name set for the DHCP scope? If not, try setting it to an empty string. This will clear the 'Connection-specific DNS Suffix' for the LAN adapter and use the 'Primary DNS Suffix' value instead.

Collapse -

Our router dishes out IPs

by mdphoenix In reply to Maybe this will help???

Thanks for the reply!

That's an excellent idea, however, our Sonicwall Router dishes out the IPs. Not the server. I'll check the Sonicwall to see if there are options available like in Windows Server DHCP.

Thanks again!

Collapse -

did you resolve it?

by d33z In reply to Our router dishes out IPs

I'm experiencing the same issue on my remote sites. Some hosts Primary DNS suffix is blank and is supposed to be set via the gateway router (dhcp server). I don't manage the router, rather AT&T does, but not all hosts in the remote offices have a blank suffix listed in their IP settings. This is causing me quite a headache, so any tips or help would be greatly appreciated!

Collapse -

Nope

by mdphoenix In reply to did you resolve it?

Not really. Since most people's home scopes are 192.168.1.x, I changed ours from that to 10.1.14.x. This has sort of resolved the issue. Actually, let me rephrase, it has gotten rid of the original problem. But now I have some computers which only show their netbios name it seems like. What I mean is, if I run an IP scan, I get some computers returning their name in all caps. Ans some return their name in lowercase with the .domain.local at the end.

I have no idea what's going on.

Collapse -

Try this...

Try disabling the 'User this connection's DNS suffix in DNS registration' option in the adapter's DNS configuration.

If the PC is member of an active directory domain, you can use group policy to modify the dns settings (under 'Computer Configuration\Administrative Templates\Network\DNS Client') or, if it's not a domain member, you can add policies manually to the registry under 'HKLM\Software\Policies\Microsoft\Windows NT\DNSClient'.

The settings applied here will override those coming from the router.

Collapse -

Thanks. I'll give it a shot.

by mdphoenix In reply to Try this...

I appreciate the detailed information. I'll try it and report back.

Back to Hardware Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums