Connectivity Problem - Computer connects on a switch but not in another

By rciafardone ·
Hello. We have a strange situation with the network. We bought 2 new machines, they connect to the network without any problem when plugged in one switch, but don?t even send a package when connected to a different switch in the network. Weird thing is an old computer with the same IP and NAME does connect on that same place with the same cable. What can it be?
We work on a domain with static IP?s, switches are of different vendors and connected in cascade.

This conversation is currently closed to new comments.

9 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Give it a new IP

by ThumbsUp2 In reply to Connectivity Problem - Co ...

The old IP is probably assigned to a specific MAC address which would be different on a new machine even though you've given it the same NAME. Try assigning a different IP within the same range and see if it connects.

Collapse -

Already tried, not working

by rciafardone In reply to Give it a new IP

We have already tried giving it a new IP, the problems seams to but not in the domain but in the card/switch. The machine simple doesn't PING to any other IP in the network no matter the IP we gave it.

Collapse -

Switch Compatibility Issue

by brian In reply to Connectivity Problem - Co ...

I had a problem similar to this, but instead of the computers not connecting, it was the switches. It turned out that our linksys and dlink switches did not like each other. We replaced the dlink with a linksys and everything worked great. Could it be a possibility that the computer and the switch are not compatible with each other? Try moving the cable running from the switch to the computer to a different switch and see what happens if assigning it a new IP address does not work.

Collapse -

Indeed, i suspect the same

by rciafardone In reply to Switch Compatibility Issu ...

I think that's the problem, since the machine DOES CONNECT on a different switch. I formatted, installed the system and added it to our domain in my "workshop/office", everything was OK. When i plugged it on the assigned office (which is on a different switch)it didn't connect.

Collapse -

Flush DNS cache?

by tmalo627 In reply to Connectivity Problem - Co ...

From what I'm reading it appears to me that you are replacing an old machine with a new one in a domain environment. What it sounds like to me is that the DNS records are still associated with the old machine. Try to flush these records and see what happens.

Collapse -

Yes, you are right but is not that..

by rciafardone In reply to Flush DNS cache?

Indeed it is a new machine replacing and old one, as i already explained this new machine DID CONNECT to the domain on a different switch, But when i plugged it on the other switch no connectivity was possible. Cable is not the problem because a different machine on that same point does connect. Al references to the old machine were wiped from server and server was restarted.

Collapse -

Managed switch or unmanaged?

by tmalo627 In reply to Yes, you are right but is ...

If it is an unmanaged switch, a simple power cycle can reset the routing tables. If it is managed, try logging into the UI to see if you can reset the tables there.

Collapse -

my first thought was port security but then

by CG IT In reply to Connectivity Problem - Co ...

you don't say whether the switches are managed or unmanaged.

with port security on a managed switch, only the computer with the assigned MAC address can connect. On Cisco switches, typically what happens is the port is disabled if an unauthorized computer tries to use it. Only the administrator that knows the switch password can turn the port back on.

Given that you tried the old computer and that works, new one doesn't, the port doesn't seem to be disabled.

if your not on the same subnet, you won't pass packets so that might be the problem.

need more information. subnet, gateway etc.

Collapse -

Not Managed. No matter got solution. Thanks Everyone

by rciafardone In reply to my first thought was por ...

I solved this. After some research i found someone speaking about network card not being able to negotiate speed with switch. the solution is to manually set the speed from auto to 10Mbs/full duplex and bang it connected. I Don?t understand why old machines could do it but new ones don't. It happened not only with one but with 2 new pcs, one with an asrock MB and another MSI MB. motherboard, i guess they use the same chip for the network card... Again thnk you everyone for the input.

Back to Networks Forum
9 total posts (Page 1 of 1)  

Related Discussions

Related Forums