• Creator
  • #3949105

    Consistent ping spikes

    by enuru99 ·


    Whenever I launch a multiplayer game/run a speedtest etc, my ping skyrockets to 100-3000 every couple seconds, this only happens on Wi-Fi, not ethernet (tried a different wireless adapter). I’ve gone as far as to reinstall windows but the issue stayed. Any programs I can use for troubleshooting?

You are posting a reply to: Consistent ping spikes

The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our Community FAQs for details. All submitted content is subject to our Terms of Use.

All Answers

  • Author
    • #3949155
      Avatar photo

      Re: ping

      by kees_b ·

      In reply to Consistent ping spikes

      To exclude possible causes (which are unlikely indeed) outside your house ping your WiFi-router, your nearest mesh station or your modem. You didn’t tell about your WiFi-hardware, so I mention a few options.

      Also see the WiFi-part of ttps://

      No need to reinstall Windows, by the way. Running ping in a bootable version of Linux is free and easy. Pinging from your Android phone (disable 3G/4G/5G data) has the added advantage that you can investigate the effect of location in your house.

    • #3949217
      Avatar photo

      Because WiFi can be easily interfered with.

      by rproffitt ·

      In reply to Consistent ping spikes

      I suggest the gamers get wired. If they can’t run Ethernet then a Powerline Ethernet kit is best. You didn’t mention much about your WiFi, neighbors etc.

    • #3949292

      This helped me

      by old molases ·

      In reply to Consistent ping spikes

      If you are experiencing constant ping spikes every 30-60 seconds or so, it might be do to your WiFi trying to search for networks. Here is how to disable this feature.

      in your windows cmd, type in

      netsh wlan show settings

      and one of the last things might say

      Auto configuration logic is enabled on interface “Wireless Network Connection”. if that’s the case, then type in

      netsh wlan set autoconfig enabled=no interface=”Wireless Network Connection”

      It should respond with

      Auto configuration has been disabled on interface “Wireless Network Connection”.

      If it doesn’t, then you might have mistyped your interface=” part. Check in your adapter settings, you might have Wireless Network Connection 2 or 3 etc.

      This will definitely stop your wireless card from searching for nearby networks and updating your signal quality when you’re not asking it to which is what is causing the spikes.

      You will need to turn it back on if you disconnect or need to be able to find nearby networks again. To do so change disabled to enabled from the earlier command or copy paste

      netsh wlan set autoconfig enabled=yes interface=”Wireless Network Connection”

      Good Luck!

      Note: instead of “Wireless Network Connection”, it may be “Wi-Fi” for you. Use that instead

Viewing 2 reply threads