Question

Locked

Converter failed to open file

By T0C ·
When a user tries to open an .xslx file on our terminal server they get the following message... 'Converter failed to open file.' When I log in as administrator I can open the file perfectly... Office 2003 professional is installed with the most up to date file format converter installed and all the latest microsoft updates installed also.
We have changed to the permissions on all the office .exe programs to everyone access in a hope this would work. The file format converter was installed to be 'run as administrator.'
Also, I have tweaked to DCom settings to allow access permissions on the office converter files.
Office has been removed and then reinstalled.
Still getting the message 'Convert failed to open file.'
Does anyone have any idea on a fix? Is there some permission that I've missed?

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

Possibly the file could be corrupted....

by Peconet Tietokoneet In reply to Converter failed to open ...

Possibility is that FileFormatConverters.exe was corrupted. Try a new download and then run it here:
http://www.microsoft.com/downloads/details.aspx?familyid=941b3470-3ae9-4aee-8f43-c6bb74cd1466&displaylang=en

Other ways to read the xlsx files from Excel 2007:

A. The free Microsoft Excel viewer:
http://www.microsoft.com/downloads/details.aspx?familyid=1CD6ACF9-CE06-4E1C-8DCF-F33F669DBC3A&displaylang=en

B. The free Open Office suite:
http://www.openoffice.org/

Collapse -

Tried that

by T0C In reply to Possibly the file could b ...

Hi mate,

yea we have tried multiple downloads of the fileformatconverter to no avail.

Also, as it is being run on terminal server we need users to be able to edit the .xslx files.

(so the viewer is out of the question i'm afraid)

Collapse -

I have read

by jfuller05 In reply to Converter failed to open ...

that not all 2007 excel formulas are compatible with 2003 excel.

Can the files be saved in the 97-2003 file format?

Collapse -

Multiple files

by T0C In reply to I have read

Yea we have tried multiple files... even tested a worksheet with a basic addition function in one cell and it wouldn't open it.

As there are hundreds of files (about 400+ users) converting them to 97-2003 format is out of the question.

Collapse -

wow, yeah, I understand that converting to 97-2003 is out of the question.

by jfuller05 In reply to Multiple files

So, forgive me if you already stated this, you probably want to edit the files on the terminal to? If not, could you open the files as pdfs?

I wonder if you could save the files to the terminal's hdd and then open the via the open dialog box in excel. Sometimes the converter does not kick in when opening the file from an email or from windows explorer.

Collapse -

This is a tough one

by T0C In reply to wow, yeah, I understand t ...

Yea, we've tried opening the files from a share on another server as well as directly off the terminal server. They do need to be edited so I guess pdf is also out.

Tried opening the file through the dialog box in excel as well as 'open with' the excel converter .exe file. No luck.

We have some sort of a hunch that it's a hidden permission somewhere or maybe an update. however, we've peeled back the updates and then reinstalled them. No luck with that one also.

Quite baffling actually... had four sys admins look at it and still fix. So serious kudos to anyone that comes up with one!

Collapse -

Do the users have execute permissions where the converter

by seanferd In reply to This is a tough one
Collapse -

Execute Permissions

by T0C In reply to Do the users have execute ...

Yip... we have granted them full access to the converter .exe files

Collapse -

Temporary storage?

by TobiF In reply to Converter failed to open ...

Does the converter use some file location for temporary storage (where you need to grant access)?

Collapse -

Temporary Storage

by T0C In reply to Temporary storage?

Hi, that was a good one... I applied the everyone permission to the office temp folder in Application data under the administrator account. Still no luck though.
Is there somewhere else that it could be hidden?

Related Discussions

Related Forums