Question

Locked

CPU fan not working

By bgs ·
Firstly the PSU died. I replaced this and also upgraded the RAM from 512mb to 2 gig.

Now when I turn on the CPU fan doesn't turn and monitor says its not receiving any input

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Sounds like the PSU took something with it.

by seanferd In reply to CPU fan not working

Like the motherboard.

Collapse -

Make sure that all the plugs are correctly fitted

by OH Smeg In reply to CPU fan not working

Particularly any Supplementary 12 V DC Plugs on the M'Board. These are either 4,6 or 8 Pin Plugs that are required to drive the Video & CPU that are separate from the 20 or 24 pin ATX power Connector.

If you have a Power Supply without this additional Plug remove the PS and replace it with one suitable for this computer. Do Not use an Adapter to plug between the PS and M'Board as this will not provide the necessary 12 V DC from different rails and it could overload the one 12 V DC Rail that it is using causing the unit to fail again and this time do more damage.

Also check that the Video Card is correctly fitted by pulling it out and refitting it with the Power Turned off and the mains disconnected. Some AGP Video Sockets cut out very easily if the Video Card gets moved slightly and then you need to refit the Video Card.

If none of the above has any effect the PS took something else with it when it Died and instead of just the PS going to Silicon Heaven quite likely the M'Board and CPU may have gone with it.

Col

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums