Question

  • Creator
    Topic
  • #2150298

    CRW32.EXE Application error – Memory could not be “written”

    Locked

    by david.griffiths ·

    Hello,
    I am getting a popup box headed “Crystal Reports [Reportxxx] crw32.exe – Application Error” when I try to connect to any Oracle stored procedure via “Add database to report”.
    I can link to views with no problem but it takes about 2 minutes before the error occurs if I have clicked the “stored procedures” box in options. Pressing the OK button then closes the report.

    I am running Crystal 8.5 and ODBC driver CR Oracle8 v3.6 on Oracle 9.5.

    I have tried uninstalling / reinstalling Crystal and running the exe directly rather than via a shortcut, but I still cannot get it to add the stored procedure. I can link the report to a database using another machine in the office but cannot link if signed in as another user on my machine.

    Any ideas would be gratefully received,

    Thanks in advance

    David

All Answers

  • Author
    Replies
    • #2908047

      Clarifications

      by david.griffiths ·

      In reply to CRW32.EXE Application error – Memory could not be “written”

      Clarifications

    • #2908012

      Try this, it might work it might not…..

      by Anonymous ·

      In reply to CRW32.EXE Application error – Memory could not be “written”

      You can’t simply copy a DB because the DB contains machine specific info in XIR2. This used to work and there are likely others in your KB’s

      you can migrate the CMS database from the CCM by selecting the copy from data source.

      ***CMS Source***

      1) Prior to copying the CMS database it’s easiest to simply disable auditing on the source CMS database to avoid errors on the destination.

      ***CMS Destination***

      2) Create a CMS database or instance for the destination
      3) Stop the CMS and all other services (page,cache,etc)
      4) Double click on the CMS
      5) Select the configuration tab
      6) Choose copy from datasource
      7) Click specify on the CMS Data source
      8) Select source CMS database (make sure middle ware i.e. ODBC connection is installed)
      9) Select destination CMS database

      ***CMS Source***

      10) Stop CMS and all other services (page,cache,etc)

      ***CMS Destination***

      11) Start the CMS
      12) Login to CMC select servers, delete all servers associated with the source CMS if they exist
      13) Stop CMS on the destination server
      14) Double click CMS on the destination server
      15) Select the configuration tab
      16) Select the change CMS cluster name to (and choose your server or cluster)
      17) Run regedit
      18) Go to HKEYLocalMachine\Software\Businessobjects\suite 11.5\Enterprise\CMSClustermembers
      19) Ensure that only the proper members are defined (i.e. your computer name only or your cluster members only). Remove anything that was added from the source system

      ***CMS Source***

      20) Restart the CMS and all other services (page,cache,etc)
      21) Login to CMC select servers, delete all servers associated with the destination CMS if they exist
      22) Go to HKEYLocalMachine\Software\Businessobjects\suite 11.5\Enterprise\CMSClustermembers
      23) Ensure that only the proper members are defined (i.e. your computer name only or your cluster members only). Remove anything that was added from the destination system

      ***CMS Destination***

      24) Delete any directories in the businessobjects\businessobjects 115\filestore
      25) Copy your FRS from the source businessobjects\businessobjects 115\filestore to businessobjects\businessobjects 115\filestore on the destination
      26) Restart CMS – Done

      NOTE: If XI replace 115 with 11. IF CE10 replace business objects with crystal enterprise and 115 with 10
      http://technicalsupport.businessobjects.com/cs/forums/thread/20162.aspx

      Please post back if you have any more problems or questions.

Viewing 1 reply thread