Question

Locked

Custom service is giving errors

By lmalhoit Contributor ·
This is kind of a weird one. Basically I have an application that runs reports. In the process of creating the report, it takes a number and converts it to a 3 of 9 barcode. This works fine when I run the application manually. However, when I try to run the application using a service that has been created, it doesn't convert the barcode. It just gives me the number in between two asterisks. Any ideas?

This conversation is currently closed to new comments.

6 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Tough to answer...

by cmiller5400 In reply to Custom service is giving ...

Maybe the service doesn't have rights to a file it needs access to?

It could be a plethora of different things. Maybe it needs the "allow service to interact with desktop" check box checked in the log on tab of the service? Without seeing the code for the application, I doubt that anyone would be able to help you.

Collapse -

Application works manually, though

by lmalhoit Contributor In reply to Tough to answer...

If I run the application manually without using the service, it works, though. It should just do the same thing. I tried changing it to local system and checking the interactive desktop, but it didn't work. I changed it back to the logon we were using before which is a user who is a local administrator on the machine. They should have the necessary priveleges. Any other ideas?? Thanks for your help!

Collapse -

Two different methods...

by cmiller5400 In reply to Application works manuall ...

You can't expect a program written for a GUI to run as a service without problems. They are two different beasts all together. Are they the same executable? If the same, is there a switch to tell it that it should be running as a service? Again, without seeing the code you have written, it is near impossible to find out what is causing the problem. It could be that the bar code generator is referencing a form that can't be created...

I just reread your first post, and I have a question: Is the program designed to be run as a service or are you just hacking it into the registry trying to get it to run as one?

Collapse -

Figured it out

by lmalhoit Contributor In reply to Two different methods...

Thanks for the replies! I actually got the answer. If you're interested refer to this:

http://forums.oracle.com/forums/thread.jspa?threadID=689400&tstart=45

Collapse -

Well...

by cmiller5400 In reply to Figured it out

You neglected to mention that you were working in ORACLE!!!

Details, details, details.

Collapse -

Relative pathnames?

by Bizzo In reply to Custom service is giving ...

Does your application use relative pathnames to access any files? e.g. the graphic files to show the barcodes etc.?

Without knowing anything about the application, try moving the application (just the .exe if possible, no other files) to another location, maybe to another drive, and run it manually from there. If it gives the same result as running it using a service, it might be that it can't find your "other" files. Try using absolute pathames in the application (if it's possible), or adding your application file locations to the PATH system variable.

Back to Software Forum
6 total posts (Page 1 of 1)  

Related Discussions

Related Forums