Question

Locked

Default printer cannot be set - Windows 2003

By sean ·
This is an error I receive when adding printers on Windows server 2003. I cannot set any of the existing printers to the default printer.

I cannot print preview or print from Excel, MS Access, Adobe Acrobat and several other products.

I can print from Word as well as IE7.

If I log out as the user and then log back in as administrator I have no problems.

The current user is a member of the administrators group, so it is not a "rights" issue.

I have also gone into the Group Policy editor and checked that the [print] components do not specifically stop the user from using the printer.

I am reluctant to just delete the user profile and recreate for 2 reasons.

1. It is seems to be an inelegant solution because it circumvents the problem instead of solving it and

2. I need to understand the underlying mechanism that seem to have failed that brought this problem about.

I have reviewed many of the discussions related to this topic on the internet. Most seem to point to the policy-type of problem.

There have been several references to a possibly corrupt registry key. One solution suggested that I log into the working profile and copy out the [device] section of the registry and then import it into the malfunctioning profile.

When I tried this, I found that the specific key was missing from the working profile and so could not export it.

I have been going through TECHNET and several of the other resources to no avail. Maybe I am just being a complete dork/idiot/dunce. I'm not sure.

Has anyone found a solution to this yet?

Sean

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Did you find a solution?

by lists In reply to Default printer cannot be ...

Hi there,
have you been able to resolve your issue? I'm running into the exact same problems ...

Cheers,

Andreas

Collapse -

Possible spooler or driver issue

by Timbrewolf In reply to Did you find a solution?

I've run into this problem in a few different scenarios and it's always difficult to figure out... Primarily, I ran into it on a Win2k3 Server using Terminal Services and it was not a permissions issue.

My best solution to try first is to make sure there's not something that's frozen the print spooler. Easiest way to do this is from command prompt:
cd %windir%\system32\spool\printers
net stop spooler (to release spooler control on files)
del *.* (to remove any files that may be here)
net start spooler (to restart the service)

If that doesn't work, it's very likely a driver problem. If you go to Printers and Faxes and right-click on the background, you can click on "Server Properties" and open the full properties. Then you can click on the "Drivers" tab and see ALL the print drivers on your system.
Depending on how many different printers you have installed, I'd remove those (or at least the most recent) and reinstall a fresh copy in case of possible corruption.

Best of luck! I keep saying I hate dealing with printers, and it seems the more I say that the more I'm working on issues like this.

Collapse -

Thanks

by lists In reply to Possible spooler or drive ...

Hi there,
thanks for your reply. Unfortunately, your tipps didn't help me.
My problem however is solved. What I did is
- remove the computer from the domain
- delete the computer account in AD
- wait for AD replication to occur
- add the computer to the domain

Why this helped I do not know, but now I'm happy :)

Andreas

Collapse -

Doubt

by shiva_4645 In reply to Thanks

whether you have added the computer account from the different name or with the same name? whether the same user profile did it worked ?

pls reply

Collapse -

Cannot set default printer in Windows 2003 Server STD Edn

by crispinnj In reply to Default printer cannot be ...

1) Remove viruses , spyware and malware . You can use combination of Megabytes Antimalware and NOD32 Business Edn.

2) Remove all the print drivers from registry or printer server propertes

Make sure you take system state backup and registry backup before take the steps below.

3) Export HKEY_CURRENT_USER\SOFTWARE\MICROSOFT\WINDOWS NT\Currentversion\Windows\ from another server or from another account in the same server

4) Import into the current user.

5) Install printers now and check.

Collapse -

Didn't know it was solved already.

by crispinnj In reply to Default printer cannot be ...

I am new comer in the blog. I came to know that the problem had already solved after posting my tip.

Collapse -

I had this exact same issue...

by benbrown44 In reply to Default printer cannot be ...

what resolved it for us is to copy a "working" NTUSER.DAT file to the corrupted user profile (while the problem user is logged out).

you may be able to do a simple copy from one profile to the other, but what we did was the following:

righclick My Computer
go to properties
go to system tab
in User Profiles section, click Settings button
scroll to and highlight working profile
click Copy To button
browse to destination location
as for permitted use, i chose Domain Users

this provides you a clean copy of the selected working profile to copy the NTUSER.DAT file over to the corrupted profile.

hope this helps.

Back to Networks Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums