General discussion

  • Creator
    Topic
  • #2257250

    Defrag

    Locked

    by nu4ever ·

    I’m trying to defrag my computer and it keeps telling me ther isn’t enough free memory close some programs and try again. I have closed and deleted programs and still get this information.

All Comments

  • Author
    Replies
    • #3232011

      Reply To: Defrag

      by nu4ever ·

      In reply to Defrag

      I’m running win 98se on this computer with 512mg of ram.

    • #3276994

      Reply To: Defrag

      by hal 9000 ·

      In reply to Defrag

      The memory that is being referred to here is Virtual Memory not Physical Memory so you need to look at the Swap File. If your HDD is getting nearly full you may have a problem here as there will not be enough room for the Swap File to load. Conversely if you have a lot of HDD Space it’s possible that the Swap File is too small.

      You can alter the size to something bigger by going into Settings then System then Advanced and Virtual Settings and chose the Swap File from there. With 512 MEG of RAM the size should be at least 756 MEG on the low side and 1 GIG on the High Side. Remember to apply the changes and then try again. This should cure your current prob em unless the drive is full in which case you are going to have to backup your data and clear some space on the drive to give it enough room to perform this operation.

      Col

    • #3276993

      Reply To: Defrag

      by gary56789 ·

      In reply to Defrag

      First, open MSCONFIG from the run dialog box. On the Startup tab, uncheck everything except your firewall, spyware and AV apps, reboot, defrag.

      If defrag still won’t run, disable Virtual memory (double-click the System icon in Control Panel, Performance tab, click the Virtual Memory button, select “let me specify…”, then select Disable Virtual memory”, confirm). Try defrag.

      If still no go, browse your setup CD to the Tools\Mtsutil folder. Right-click “defrag.ini”, select Install. When you reboot, Defrag should run at startup.

      Be sure to return your Virtual Memory settings to their original state when finished.

    • #3209619

      Reply To: Defrag

      by thechas ·

      In reply to Defrag

      Sounds like you are being hit by the Windows 98 large RAM bug.

      Check out this MS article:

      http://support.microsoft.com/default.aspx?scid=kb;EN-US;q253912

      Change the MAXCache setting, and you should be good to go.

      Chas

Viewing 3 reply threads