General discussion

Locked

delete a directory ending in period

By reiki33 ·
I only solved this by wiping the disk. On UNIX I made a cpio file of nested directories that broke a long name into 14 character chunks, with the remainder the real file in a series of directories of the name chunks. Some directories ended in a period. Using pax to restore the cpio image on win2k, I got directory names ending in period. I could not delete them. Windows explorer could not open them. Command shell could not delete or rmdir them, even with partial name matches, like rmidr XXX*. I had a C program try to remove them and fail. Did I miss something, or were these so illegal the windows file system could not deal with them. No one I ever showed them to could remove them. How was pax able to create them in the first place?

Thank you in advance.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by AmberHaze In reply to delete a directory ending ...

Not certain, but I did run into a similar situation once. In my case it turned out the files / folders were created with an invalid owner flag. The remedy was to select the root folder and force ownership to administrator... I was then able to work with the files.

Hope this helps in your situation

Collapse -

by reiki33 In reply to

Poster rated this answer.

Collapse -

same problem, no solution

by djh02139 In reply to delete a directory ending ...

I have WinXP. Ended up with a folder ending in TWO periods! I think this happened when an application tried to create such a directory. So the Windows API must allow someone to try to do this. Like said above, no amount of tweaking through Explorer GUI or command prompt can remove...

Back to Windows Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums