General discussion

Locked

Dell 2400- proprietary PSU?

By TracyF ·
I'm trying to figure out what the culprit is on a Dimension 2400 tower.

Error, at boot, is "Primary drive 0 not found".

I ran the Dell diagnostics which finds & reports the drive ok. Reseated & tested RAM. Reseated all cards (phone modem only).

When I first looked at the tower, I saw the backplate was loose & snapped that back in- the unit started right up- so I thought- "hmm, maybe a ground or such"?. I ran MS updates (most were done). I've seen this same unit, about 4-6 mths ago- same error- where I replaced the IDE cable & battery. It has run fine since that time.

Since then, RAM has been added & also every USB port filled. The current PSU is 200wts. I'm wondering if it may be failing & just not able to supply proper power?

I have a PSU tester- but it's quite basic- doesn't actually give what each line is outputting.

This morning, I started the PC & came to the same screen. I was standing next to it, looking at my previous notes, when I suddenly heard the hard drive spin up. The darned thing is so quiet, I hadn't noticed it was not running until I heard this (actually, once it spins up, there is no real noise from it). Again, does this sound like PSU?

Next, was to try to find whether this model is standard ATX. I found a schematic on the Dell site & the wiring diagram does appear the same as standard.

Is there anyplace that has this info posted (which Dell or others are standard)? Or, has anyone here replaced the PSU in a Dimension 2400 w/ATX?

TIA,

Tracy

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by HAL 9000 Moderator In reply to Dell 2400- proprietary PS ...

Antec used to have a pin out designation on their web site under the technical specifications of their PS's.

I very much doubt that the pin outs would be different but you could run into problems when you try to fit a new PS to the case many will not fit without modification to the case.

Col

Collapse -

by mjd420nova In reply to Dell 2400- proprietary PS ...

This sounds like a cold solder joint on the
drive power supply connector. I've experienced
this same thing. As soon as I touched, wiggled
or moved the wire bundle, the drive would start
okay, and after a couple hours it would stop
spinning, or refuse to start after running
fine.

Collapse -

by ozi Eagle In reply to Dell 2400- proprietary PS ...

Hi,

Following on from a previous answer, about dry joints in the HDD power connector, I have experienced that the sockets can become loose and give intermittent contact, particularly if they have been removed and replaced a few times.
The fix that I found is to use a small instrument screwdriver and push it into the socket, between the plastic shell and the metal contact, so that the metal socket is slightly squeezed close. Gently though it only needs a little bit.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums