General discussion

Locked

Dell Optiplex 110 sometimes doesn't detect the Hard Drive

By eraser3498 ·
I have a Dell Optiplez 110 and just replaced the hard drive in it. (old drive Maxtor 40Gig New Western Digital 80) Now sometimes for whatever reason the drive is not detected in the bios it says unknown device on IDE Master. It was working well before and I haven't made any other changes. I suspect bios battery or ribbon cable, are there any other things I should be looking at? The bios is the most recent one A09. Any information you can provide is greatly appreciated. Thanks.

This conversation is currently closed to new comments.

7 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by wcp In reply to Dell Optiplex 110 sometim ...

BIOS, battery, IDE cable, Power connector, Power supply, and MB.

If you have another system, connect the HD to the system. If you get the same kind of problem, the HD is the culprit. If there was no problem, then check IDE cable, power connector, and battery.
If the problem is still there, it?s got to be the MB.

If you do not have another system, try different IDE cable and Power connector. Try connecting the HD only. The idea is to eliminate all possible causes one at a time. Whatever left must be the culprit.

Collapse -

by eraser3498 In reply to

Poster rated this answer.

Collapse -

by HAL 9000 Moderator In reply to Dell Optiplex 110 sometim ...

As the above poster stated you can do those things but to make it faster download the HDD makers testing utility and test the drive. If it comes up as Bad then test in in another computer and see if it still comes up as bad if it does the HDD id on the way out and should be replaced and you'll need to do a data backup.

If it shows up as OK on another working computer it will be the M'Board IDE controller so that means a new M'Board or a replacment one at the very least.

Col

Collapse -

by eraser3498 In reply to

Poster rated this answer.

Collapse -

by sgt_shultz In reply to Dell Optiplex 110 sometim ...

sounds like a spinup timing problem. the drive may be 'adjustable' via firmware. get the model number and we will look it up for you on the wdc.com website...

Collapse -

by eraser3498 In reply to

Poster rated this answer.

Collapse -

by eraser3498 In reply to Dell Optiplex 110 sometim ...

This question was closed by the author

Back to Hardware Forum
7 total posts (Page 1 of 1)  

Related Discussions

Related Forums