Question

Locked

Dell Optiplex GX280 Issues with adding a 2nd HD

By chrishov ·
I am running a dell optiplex gx280, my setup up till now was 1 sata hd , and 1 dvd/rw combo. The sata is set to sata master and dvd to master IDE. I just installed a 2nd harddrive IDE and had to slave it off the DVD drive as I only have 1 IDE connection port on my motherboard. Both harddrives are working fine and detected, and the DVD is working in windows but in my bios the DVD isn't showing up it says no device present or something to the effect under the master ide slot whereas the IDE harddrive is showing up fine under the slave ide slot.

I have tried setting via jumpers the DVD as both master and cable select and also tried setting the HD as both slave and Cable select. The fact that the drive works tells me the pc is recongnising it but I need it to be recognised in the bios so I can use it as a boot drive to install windows xp, as my copy is seriously riddled with spyware/backdoors etc.

Any assistance would be greatly appreciated thank you!

This conversation is currently closed to new comments.

11 total posts (Page 1 of 2)   01 | 02   Next
| Thread display: Collapse - | Expand +

All Answers

Collapse -

have you tried

by jck In reply to Dell Optiplex GX280 Issue ...

making the DVD the slave and the HD the master?

also, check Dell forums. They might have a bios update or a cure for that.

sounds weird tho. could be the identifier on your DVD is out too.

Collapse -

Not possible but ty

by chrishov In reply to have you tried

the way the case is setup the larger bay is on the right for the cd/rom drives while a smaller bay is on the right for the HD's etc... being the cable goes from right to left meaning the mid connection left then the end connection right only possible to connect it as cd/rom master and hd slave.

I will add that I forgot to mention the Cd/rom and sata worked perfect together no issues, the sata and IDE work perfect no issues just trying to get the third to work is not going so well.

I'm wondering if I need to adjust the jumpers on the sata HD at all? right now they're set to opt1.. there's also opt2, ssc and another option on there... it's a Western Digital 160gb SATA. Cavier model js1600 or something..

According to dell's documentation the IDE slot should support 2 drives just fine unless they're both the same ie. 2 hd's or 2 cdroms.

Only other thing I can think of is getting a sata to ide converter cable and trying the cdrom as a slave to the sata however I heard those converter cables have a very poor success rate and being that my machine is a crappy dell... well I have little faith.

I tried cable select on the cd/rom master and slave setting on the HD still shows HD as slave and no cdrom in bios also tried putting both as cable select, again hd works and no cdrom in bios... what's strange is the Cdrom works just fine in windows with no errors at all.

Thank you for your reply!

Collapse -

i don't think so

by jck In reply to Not possible but ty

the SATA and the EIDE channels and controllers should be addressed independent of each other in the system.

Just a silly question maybe to ask: have you tried not putting the jumper on the DVD? or gotten a 2nd DVD drive and tested to see if it's got an issue?

Just curious and more thoughts...hope it works out for ya

Collapse -

Possible solutions..

by NormH3 In reply to Dell Optiplex GX280 Issue ...

I would agree that you should try making the DVD a slave, but if there is a cable problem, that advice isn't very helpful. There may be a third party cable available that would make the hardware configuration doable. My only other thought would be to get a PCI disk adapter that would allow you to install the second drive on it's own cable. These adapters come in IDE and SATA flavors.
One last thought.. Dell is notorious for using PSU's that have just enough of a wattage rating to support a desktop in a standard configuration. By adding a second hard drive, you might be nearing the "wattage threshold".

Collapse -

Results of making HD master and DVD drive slave...

by chrishov In reply to Possible solutions..

I managed to get the IDE hd set up as master and the dvd rom as slave... the result is now my dvd rom shows up in bios but the ide hd does not...exact opposite of before.

I'm starting to wonder if the ide controller on this mobo can handle 2 ide devices at once.. although if it can't I don't know why the system has a hd cable with 2 connections then. Perhaps it's a bios issue? As windows detects the HD still and is accessible.. perhaps the bios cannot display 2 ide devices?

Still just as confused as before I even switched out the hd cable to an asus cable that is pretty much brand new to no avail.. I don't think it's a cable issue however or 1 of the 2 devices would not function even in windows.

Thank you for your assistance.


Perhaps it would help if I describe what I'm trying to accomplish.. I want the Sata drive to be for gaming only and I want windows and data on my IDE. In order to be able to install windows I also need my dvd drive to be bootable. Being that the sata is my main drive in bios and I don't believe I can set it to slave without having something else as master on the sata channel.

I understand a few of the boot files for windows will be put on the sata no matter what and the rest will be installed on the IDE. That's okay with me at least most of the programs that windows will be running will stress my ide instead of my gaming drive.

Collapse -

Have you tried setting both to CS Cable Select

by OH Smeg In reply to Results of making HD mast ...

And then attaching them to the IDE Lead?

The 80 Way IDE Leads are set so that the End Connector furriest from the M'Board is Master and the Middle connector is the Slave Drive. The Hardware will auto set these.

But having said that it is not possible to have 2 Floppies on most of the EP43 and 45 Chip Set M'Boards so it may be possible that this M'Board doesn't support the Ability to use 2 IDE Devices here or maybe the PS is so underpowered that only the Master on the IDE Channel can be recognized and provided adequate power & current.

Can you try a different PS not mounted in the case to test with?

Col

Collapse -

Thank you

by chrishov In reply to Have you tried setting bo ...

The issue was resolved by resetting bios to factory settings suddenly all 3 devices showed up just fine in the bios. I thank you for your tips though and wish you the best! Cheers.

Collapse -

Your Welcome <NT>

by OH Smeg In reply to Thank you
Collapse -

Just wondering

by philldmc In reply to Dell Optiplex GX280 Issue ...

What is the power supply size? Some of the dell computers I have come across have tiny power supplies not powerful enough to support beyond what was included with the unit.

In addition check the bios on the IDE/SATA settings make sure the IDE channel is set to dual or both, a setting enableing two devices per IDE channel, not sure what the exact wording is in the bios.

Have you tested the hdd in another system?

Collapse -

Solution!

by chrishov In reply to Just wondering

Thanks to the guys at FixYa the solution was to reset bios to factory settings and restart after that everything's showing fine! Thanks everyone for your help!

Back to Hardware Forum
11 total posts (Page 1 of 2)   01 | 02   Next

Related Discussions

Related Forums