Dell xp laptop has connection to Linksys router but can't get IP address

By bamac86 ·
The setup: I have 4 computers connected to my Linksys wireless G WRT54GS router. Computer A (Dell dimension desktop running WinMe), Computer B (Dell dimension desktop running Win98), Computer C (Dell dimension desktop running WinXP), and laptop (Dell inspiron 6000 running WinXP Media Center). Computers A & B are wired, computers C & D wireless.

Problem: Computers A, B, & C are connected to the internet and can share files. Up until 3 days ago my laptop (Comp. D) was also able to do all this. I shut it down one day, opened it the next, only to be locked out of the network and no internet access.

My wireless signal is just fine. So, it's not the network card. I installed a new driver just in case. No help.

With my TCP/IP configured to automatically obtain IP address, it would hang when trying to get IP addy. So, I manually configured it (not really knowing what I was doing) and it did at least connect to the network, but still no internet and I am not seeing any other computers. My configs are:

IP Addy:
Default Gateway:
DNS Servers:

It is showing the correct MAC address for my wireless card, and I entered the same MAC into the router setup. My network key is correct.

My "Wireless Connection Status" says I have sent and received 25 packets at 54 Mbps. (You could have fooled me!)

ANY CLUES as to what my problem might be would be extremely helpful.


This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Answers

Collapse -

DNS servers

by CG IT In reply to Dell xp laptop has connec ...

DNS servers are always your ISP DNS server addresses.

For comp D with a set address, use the ISP DNS servers and you should be able to get to the internet.

As far as accessing shared files and folders on the network, my suggestion would be to start from the beginning and setup the comp as if it was not already setup for the workgroup. Verify that your wireless network card and the wireless utility are actually working correctly and that you are using the proper WEP/WPA key. Its possible that the wireless utility you use to connect decided to "run on the mumbo".

Collapse -

I feel like an idiot...

by bamac86 In reply to DNS servers

my antivirus software has one place (that you can only get to by right clicking the icon in the task tray) which you click or unclick to halt internet traffic. Well apparently my son had clicked it and I didn't realize it. After all that changing and manually configuring settings, still not being able to get on, it occurred to me to right click the icon. Voila! I am now connected. I redid my settings to automatically detect my IP address.

Why it didn't occur to me to check this hours before I will never know. Bet I won't forget again!

Thanks for your time.

Collapse -

Thank you bamac86

by terryhertel In reply to I feel like an idiot...

I did what you suggested and it worked!
Thank you so much!

Related Discussions

Related Forums