Question

Locked

device drivers

By allester58 ·
I have a Lenova 3000 c200 notebook that came with Vista Business installed. I replaced it with XP homeSP2. I was able to load all drivers except for three of them. They all are listed in Device Manager as,"Base System Device" I have downloaded everything from the website and they are still there. IBM techs have no Idea what they are and Lenova wants 70 dollars to try. Can anyone help?

Thanks,
John

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

This may help

by Jacky Howe In reply to device drivers

http://www.driversdown.com/driverslist/s_437_1.shtml

Base System Device

http://www.intel.com/cd/channel/reseller/emea/eng/332966.htm

Collapse -

Device By Connection

by TheChas In reply to device drivers

When I am faced with the unknown device question, I start by setting Device Manager to show devices by connection. That way, I have a better idea what the device is.

On your notebook, I would also take a close look at the specification sheet and see what hardware is supposed to be there that is missing.

Have you tried removing these devices and letting Windows find them again on a re-boot?

Wireless, Sound and video devices are common items for XP to have trouble with when you downgrade a new system. Are all of these devices present?

Chas

Back to Web Development Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums