General discussion

Locked

DFS Problem on Windows Server 2003

By ronnie.brattfalk ·
Hi..

I have a serious problem with DFS (Distrubuted File System). The problem is the following.. The DFS is installed on our Domain Controller. but theres a high problem with it it consumes every Memory and System resource on the system.. the Processor load is 100% and its taking all thats left of the memory i got in the server.

The Hardware Specs of the server is:
Its a Compaq Proliant
4GB of RAM
4 x 1400Mhz Processor
750GB Harddrive

It should be enough and i have tried to apply the following patches that microsoft themselves recommended to solve the problem..
Windows 2003 Service Pack 1
KB889177


Please
Can anyone help me!. i am lost on what to do

Kind Regards
Ronnie

This conversation is currently closed to new comments.

2 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by Hal2000 In reply to DFS Problem on Windows Se ...

DFS consumes memory and resources when it is busy establishing all the links and rebuilding the path informaiton. There is a utility that may help identify why this is happening in your server DFSutil.exe.

the following links should take you to the syntax info from Microsoft
http://www.microsoft.com/technet/prodtechnol/windowsserver2003/library/TechRef/06894c4e-aff0-4966-b794-e160839c3ce8.mspx

Searching the Microsoft KB dor DFS also shows a troubleshooting section. Have you gone through it?
When you first instantiated the DFS did you have problems with building the preliminary links? or is this something which has crept in after a recent change?

Collapse -

by jmason In reply to

Hi

I had the same issue on my server the other week

where one of the servers in the replication partner ship was running at 100% I tried everything from removing the files from the stagin area stopping and starting the services etc etc

In the end I looked in the Dump log in c:\windows\debug you need to locate the dfsr log with out the .dz after it and open it this is the active log file

i then notice a load of the same entries
+ [Error:9014(0x2336) DirWalkerTask::MoveinStep dirwalker.cpp:1158 4972 C313 Database failure]

I found out where the database was this is in the system volume information file on the drive i had to give my self access to this file

I then stopped the DFSR.exe service and renamed the database file and restarted the DFSR.exe service this rebuilt the database and all was fine

hope all that helps

Back to Networks Forum
2 total posts (Page 1 of 1)  

Related Discussions

Related Forums