General discussion

Locked

DHCP not detected by wifi

By blygman ·
In a few words, the problem encountered is the following :

Laptop PC with realtek RTL8180 WLAN board.
Windows XP SP2
Router with DHCP & wifi enabled.
Wireless Board driver updated to last release.
Norton Internet Security 2006 => Norton firewall disabled for tests

Surf connected by ethernet is OK.
Surf connected with wifi :
- network athentification & encryption : WPA-PSK & TKIP
- connected with 92% signal strength
- Ipconfig / all shows a 169.xxx... IP address
- ipconfig / release then /renew fails with "could not detect DHCP server .." error message even after restarting the DHCP service
- Winsockxpfix.exe run to no avail
- When the IP address is forced, it still doesn't work
- Canal change doesn't help.
- Windows zero config ON or OFF (using Realtek own WLAN software) doesn't help either.

The only thing I have not tried is to connect to another pc with wifi to check if the Realtek board is faulty, since I have only one on hand.

Thanks in advance for your help.

Francois

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

Had same prob

by ramessess In reply to DHCP not detected by wifi

I had the same problem but was a linksys card. I tried everything I could think of, it turned out to be a bad card. I do have a couple of ideas to try. Try a different encryption type, I've seen issues with this before. Also, when you force the IP can you access the router setup, or ping the DHCP's gateway address? If not, you are not connected. Look to see if maybe there is an issue with your wireless driver and your labtop's bus or PCMCIA driver. One last thought and this is just my opinion, Norton has not made a good product since 2003. Try most anything else, I like Kaspersky.

Collapse -

Auto IP configuration

by mike.farmer In reply to Had same prob

It sounds like the hardware IP address assigned at the factory is being loaded. Therefore DHCP can't assign an IP. Here is a link to change this behavior in the registry.
http://www.windowsnetworking.com/articles_tutorials/w2knoaip.html
Editing the regisrty can be dangerous.

Collapse -

That was an encryption problem

by blygman In reply to Auto IP configuration

In fact, I just changed to WEP encryption and it worked.
Thanks for your suggestions
Francois

Back to Networks Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums