General discussion


DHCP not responding - limited or no connectivity

By ted ·
I ran into a problem the other day which really wasted a lot of my time. The computer says - Limited or no connectivity. I ran winsock fixes, installed a new network card, reset router, installed microsoft patches, and then installed windows xp sp2... of which none of these fixed the problem. Norton Anti-Virus was never on the computer. My internet connections worked fine with the other 4 computers. What I am wondering is, what causes this to happen? Registry glitch, file problems, or some other thing that I overlooked?

I did the following to resolve the issue, does anyone else have any steps that they may have performed first?

note: this computer had a modem in it, and was setup with dial-up, but never used. they were unable to get the internet to work. I installed a new network card, dlink 10/100, and a 3com 905b that I knew worked good.

-removed verizon dial-up dun link
-changed ie to never dial a connection
-setup automatic proxy detection

then started the following:

-installed new network patch cable
-installed new network card
-ran winsock fix tool
-ran command netsh int ip reset reset.txt
-ran command netsh winsock reset
-ran command netsh firewall reset
-ran microsoft patch 80xxx something update
-ran winsock fix
-backup winsock keys
-ran regedit, deleted winsock, winsock2 keys
-deleted drivers for card
-re-installed network drivers
-installed ipx/spx
-installed tcp/ip under windows\inf folder
-installed windows xp sp2
-virus scanned hard drive with two different
programs, while hard drive was removed from the original pc system
-installed hard drive again
-ran winsock fix tool
-flushed dns
-installed a different patch cable
-installed original new network card
-all to no success
last resort
-repair from boot xp disc
-no good

---> the verdict, I could not figure out what the problem was...

final report - re-install windows xp home and all other software - finally fixed!

are there any other tests or recourse that a person can take? is there a registry tool that will reset the registry to how it was when xp was installed? if not, why is this not possible?

has anyone else ever ran into this problem?
I am thinking that it would have been quicker to just re-install the software again.

I know other people experience this same problem, because I spent 5 hours searching for answers, and never found an answer.

Please assist! Thank-you

This conversation is currently closed to new comments.

Thread display: Collapse - | Expand +

All Comments

Collapse -

Thank you

I run into similar situations every once and awhile. It just seems that there is no way to determine every individual problem and re-installing is the best solution. You walk away wondering what the problem was, but time is money. So having the computer working again is ultimately the only important thing.

Thanks for sharing your thoughts and troubleshooting process.

Collapse -


by CG._ In reply to DHCP not responding - lim ...

One thing that I did not see in your list was using System Restore, I had a similar problem with a fairly new computer and ran system restore and it worked fine.


Collapse -


by hugo In reply to DHCP not responding - lim ...

Hi Ted and anyone else with this problem.
I had the same problem and tried everything for 3 days straight - tried all ip fixes winsock fixes etc.
In the end I just deleted and replaced tcpip.sys - the original had been replaced by spyware. I suspect it will tried to replace this file with the spyware file next time I reboot but at least I know what the problem is.

Collapse -

Yes I believe that is the only thing that I did not do!

by ted In reply to THE ANSWER

Amazing.. I bet this will fix this problem for other people... I am going to go back to the image and see if that is the case... I will let you know.


Collapse -

have the same issue - how to replace the tcpip.sys

by sree_1203 In reply to THE ANSWER

Pls advice is there any other source get the tcpip.sys as i don't have the XP cd at this moment and far away from home..

I have the same issue, my sony vaio laptop was working fine since last two years and suddenly stopped connecting to internet through wireless or Lan cable. I can see it sends packets and not receiving, when I connected through lan cable it is able to ping the router ip. It is not able to obtain the IP automatically from the DHCP router, when I manually set the IP it says connected but don't access the internet...I tried all those mentioned..and no luck..I am not preferring to reinstall the XP as I need many installations of other applns I had.. and my sys restore is not working for some reason.
could any one respond and advice pls! it will be a great help....
thanks for your time!

Collapse -


by sree_1203 In reply to have the same issue - how ...

I got it resolved finally, the culprit was Ethernet LAN driver, reinstalled the driver software and it worked..

Collapse -

Could you fix that DHCP problem Ted?

by allavalabala In reply to DHCP not responding - lim ...

Hi Ted

I'm getting crazy trying as many things as you did to solve this problem.
There was somebody saying the reason could be the TCPIP.SYS....
Could you finally fix it?


Related Discussions

Related Forums