Question

Locked

Diconnected Network Drive despite all efforts! HELP!

By TS124 ·
I have a problem maintaining my network. The goal: to have my computers talk to each other, mainly for file sharing. GOAL: I want to be able to use my desktop hard drive as a form of network storage to back up essential files on 2 laptops. Before I begin, I feel I have done my homework & attempted to resolve this via searching all over the web (including this site & forum). I really hope someone can help. Pardon the length but there is a big history here.

MY NETWORK: Netgear MR814v2 Wireless Router
1 DESKTOP & 2 LAPTOPS: 2 running XP Home SP2 and 1 XP PRO SP2
All computers share the same Workgroup name. Logins are verified.
Desktop is Ethernet wired to router, laptops are wireless. All connect w/ internet fine.

When I boot my desktop, then laptop, the network seems to be recognized. I am able to map the desktop HD as a Z:, which is seen by the laptop for about 5-10 minutes. I am able to share Network Printers attached to the desktop, write files to the desktop HD via the laptop, etc. It seems to be all working. After about 5-10 minutes things get &*%$&* up.

The specific message I get is:
?An error occurred while reconnecting Z: to \\Home-desktop\DesktopHD. Microsoft Windows Network: The local device name is already in use. This connection has not been restored.?

Explorer shows ?Disconnected Network Drive? and (unlike others in other forums) I am UNABLE to access it any more unless I reboot, whereupon the problem repeats itself. Interestingly, if I manually edit test files on the mapped HD on the desktop every 3-4 minutes, the network remains connected. However, when I cease this it disconnects.

The symptoms suggested the network drive was being dropped after a certain time for an unknown reason. Searching found the following symptoms and (supposed) answers.

I HAVE TRIED THE FOLLOWING:

I explored the Windows help files and found:

http://support.microsoft.com/kb/297684

Briefly:
"SYMPTOMS: You find that the network drive mapping may be disconnected after 15 minutes of inactivity and Windows Explorer may display a red "X" on the icon of the mapped drive. However, if you double-click it reconnects quickly.

RESOLUTION: by default, idle connections will be dropped after 15 minutes. To modify idle time, at a command prompt using net config server /autodisconnect: minutes. For example, to set the Autodisconnect value to 30 minutes, you would run the following command line: net config server /autodisconnect:30. If you would like to turn autodisconnect off, do net config server /autodisconnect:-1."

1. Modified the Windows Registry directly via:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Service\lanmanworkstation\parameters
Value: KeepConn
Data type : REG_DWORD
Range : 1 to 65535 (sec)
Default value: 600 sec = 10 mins
In the right pane, click the autodisconnect value, and then on the Edit menu, click Modify.
On the Edit menu, click Modify.
Click Hexadecimal.
In the Value data box, type ffffffff, and then click OK.

I have entered ?ffffffff? confirmed by doing the following:

net config server /autodisconnect:-1

2. Shut off all abilities of both desktop and laptop to suspend all network cards (wireless & wired)
3. I then found the following suggestion from http://www.pctools.com/guides/registry/detail/8**/ & techrepublic.com.com:

Try [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters]

"KeepAliveTime"=dword:00300000
"KeepAliveInterval"=dword:00001000

Or Copy that to a note pad and rename it keepalive.reg then double click on it and it will do the registry change for you.

What this does is that it sends keep alive packets every 5 minutes to the server you are mapped to making the connection live and not idle.

HOWEVER, this hasn?t solved the problem. I still get disconnects. I am at a complete loss. After spending weeks on this (literally) I have been unsuccessful in getting this fixed. I am even a fairly advanced intermediate user capable of dabbling with the registry and even I cannot resolve this issue.

I would appreciate ANY help with this problem. I find it completely humbling and it is now a personal issue between me and the computers!

Thanks in advance. DM

This conversation is currently closed to new comments.

5 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Answers

Collapse -

Somewhat of a fix

by Jmoody10 In reply to Diconnected Network Drive ...

You may want to try this.
Type of a simple batch file that reconnects the drive (or remaps it in this case). Have that file run every five minutes or so. I do not think that is the best fix but it may help you out until something better comes along.

Collapse -

batch file

by TS124 In reply to Somewhat of a fix

thanks for your quick response. any suggestions on how to write the batch file? when it comes to networking & writing of such things, I dont trust my limited experience. thanks. DM

Collapse -

found a 3rd party solution

by TS124 In reply to batch file

so, after searching some more, I found a little program called Network Drive Manager v2.4 that tackles this very problem. installing it on the laptop has solved the problem! it looks like the program functions much like the KeepAlive commands I tried in the registry, by sending a inquiry every minute to keep the drive connected. so, the exact solution lies in how this program functions.

a fix, but XP should still not give so many problems. now i have to buy the program!

Collapse -

Another solution

by oliver In reply to Diconnected Network Drive ...

I have the same problem on a Windows 2000 machine connecting to a Samba domain (but logged in locally). I've created a very simple utility that will stop the drive disconnecting. See http://blocko.blogspot.com/2007/05/how-to-stop-network-drive-disconnecting.html

Collapse -

Default Network Interface setting -

by lyle In reply to Diconnected Network Drive ...

The default for power saving features in Windows XP includes turning off the network card to save power. This setting is found in the network card properties dialogue box - configure button - Power Management tab. The default is "allow the computer to turn off this device to save power" uncheck this box to resolve the issue.

Back to Networks Forum
5 total posts (Page 1 of 1)  

Related Discussions

Related Forums