General discussion


Difficulty installing USR PCI Faxmodem

By Sakartvelan ·
When installing this new modem(USR 5660A) Windows 98 can't find all the files it needs on the installation disk. As a result The Device Manager shows the following items as not installed properly (a question mark, not an exclamation point): PCI Bridge, PCI Communication Device, PCI Ethernet Controller and PCI Multimedia Audio Device. The modem works - I can dial up to the Internet. I'm just concerned that these items will cause me problems later (see my question regarding a sound card problem - related?) Originally the card wouldn't work at all, but I put it in a different slot and at least got this far. Tried downloading the drivers from USR and reinstalling, but got the same result.

This conversation is currently closed to new comments.

3 total posts (Page 1 of 1)  
| Thread display: Collapse - | Expand +

All Comments

Collapse -

by csmith In reply to Difficulty installing USR ...

Changing the PCI slot was definitely the correct thing to do.
That corrected the IRQ sharing problem.
Now in Device Manager, remove the "Not properly installed" items, and reboot.
Have the Windows 98 CD handy.
Win98 will detect the missing items, and reinstall the drivers from the CD if it can not find them.
That should correct all of the configuration confusion.
This is a lot simpler than doing a manual configure.
Regards, Chris

Collapse -

by gkheart1 In reply to Difficulty installing USR ...


It sounds like you may also want/need to
reinstall/update the motherboard drivers for
your chipset on the board. Hope this helps.

Regards, Gil

Collapse -

by gkheart1 In reply to

It may also help the sound problems too.

Back to Hardware Forum
3 total posts (Page 1 of 1)  

Related Discussions

Related Forums